Opened 11 years ago

Closed 11 years ago

#7798 closed defect (invalid)

Tree DnD regression

Reported by: rdunklau Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.2beta
Keywords: Cc:
Blocked By: Blocking:

Description

Sorry if this was already reported , but i swear i tried to find it evrywhere on trac ;)

In 1.2RC1 release, it seems the Tree DnD doesn't work anymore: on the tree dnd page, you can't drag an item from the bottom left tree and drop it on the bottom right one. In Firefox 3.0, the error occurs when the item is dropped on the tree (with an ItemFileWriteStore? error), whereas an error occurs on WebKit?-based browsers as soon as you drag it over the bottom-right tree, with a "toLowerCase is not defined on null" error. It seems that the latest is due to the fact that in _changeState(type, newstate) method, nothing is done to ensure that the newstate object is actually of type string.

Change History (4)

comment:1 Changed 11 years ago by rdunklau

Sorry, trac announced me an error so i did not noticed that my ticket was saved. Please remove either this one or #7799.

comment:2 Changed 11 years ago by bill

Component: GeneralDijit
Owner: anonymous deleted

Hmm, #7799 seems mainly about webkit but this ticket says that firefox 3 is also broken? Did FF3 start working for you or something?

comment:3 in reply to:  2 Changed 11 years ago by rdunklau

Replying to bill:

Hmm, #7799 seems mainly about webkit but this ticket says that firefox 3 is also broken? Did FF3 start working for you or something?

No, it did not. I forgot to precise the Firefox case in #7799. There are two differents bugs : one comes from some safari/webkit/else strangeness (as referred in my comment to #7799) , and another is this "assertion failed in ItemFileWriteSrtore?" when dropping from tree one to tree 2.

comment:4 Changed 11 years ago by bill

Resolution: invalid
Status: newclosed

Oh I see. As for the "firefox" problem, it's just that the test isn't setup to drag from the left tree to the right, as that tries to duplicate items (with the same id) which causes the dojo.data exception.

I clarified the comment in test_Tree.html so that's clear, in [15640]. I'll close this now and leave #7799 open, about the safari problem.

Note: See TracTickets for help on using tickets.