Opened 11 years ago

Closed 10 years ago

#7777 closed enhancement (invalid)

Add a "Not Editable" method to the "FilteringSelect" component.

Reported by: apsy Owned by: Nathan Toone
Priority: high Milestone: future
Component: DojoX Form Version: 1.2beta
Keywords: FilteringSelect Cc: dante
Blocked By: Blocking:

Description

I think it would be cool to have a method which put the component not editable by the user. Like removing the key typing listeners or something else. Like for the regular "select" tag. Because something, we would like to have the value "safe" from all editing. So a "setEditable(/* bool */ editable)" method would be really useful i think.

Change History (6)

comment:1 Changed 11 years ago by bill

Resolution: invalid
Status: newclosed

This is already supported. Use attr('disabled', true) or attr('readonly', true) to change the state dynamically.

comment:2 Changed 11 years ago by apsy

Resolution: invalid
Status: closedreopened

No this feature is not already implement. Try it yourself ! You'll see that "disabled" or "readonly", disable the whole thing ! We can't choose from the list something else...

comment:3 Changed 11 years ago by bill

Yes, that's what it's supposed to do, it disables the widget so the user can't edit (ie, change) the value.

I don't know what you mean by "put the component not editable by the user". If you want the user to be able to choose from the drop down list but not type in a value directly, you should use the dojox.form.DropDownSelectSelect widget.

comment:4 Changed 11 years ago by dante

Cc: dante added
Owner: changed from dante to Nathan Toone
Status: reopenednew

I think is is asking for individually disabled items from the store. Nathan, what do you think?

comment:5 Changed 11 years ago by Nathan Toone

Milestone: 1.3future

comment:6 Changed 10 years ago by Nathan Toone

Resolution: invalid
Status: newclosed

It sounds to me that what is wanted is the ability to NOT have people type in - but they can still select values - is that correct? If that's the case, use dojox.form.DropDownSelect?.

If you want to disable/readonly the entire widget, you can do what was suggested above.

In either case, the FilteringSelect? widget is "invalid" (so you can call widget.validate() or widget.isValid()) if the value you type in doesn't exactly match a value in the dropdown...so they can't type in arbitrary values anyway.

Closing this as not a bug - as the feature you are requesting is already available. If you want to provide some kind of mockup, so that we can understand better, feel free to attach such a mockup and reopen.

Note: See TracTickets for help on using tickets.