Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#7741 closed defect (fixed)

NumberTextBox: does not render properly in Iceweasel

Reported by: Jonathan Bowers Owned by:
Priority: high Milestone: 1.3
Component: Dijit - Form Version: 1.2beta
Keywords: dijit.form.NumberTextBox Iceweasel Cc:
Blocked By: Blocking:

Description

Due to some calls in dijit.form.NumberTextbox? to dojo.isFF, the textbox does not render properly in Iceweasel.

Using Iceweasel (you can fake this by changing your general.useragent.extra.firefox setting in about:config in Firefox from "Firefox" to "Iceweasel") if you load a page with a NumberTextBox? widget in it, the widget will not render properly.

If in Iceweasel, setting your useragent to "Firefox" causes everything to work fine.

Systems affected:

Iceweasel 2.0.0.x/3.0.x on Debian

Related ticket:

  • ticket:3974 This ticket discusses the use of dojo.isFF and indicates that the problem is NOT in an incorrect definition of dojo.isFF for Iceweasel browers.
  • ticket:7740 Another Iceweasel rendering issue related to the dijit.form.Textarea widget

Workaround:

A simple work around is to redefine the dojo.isFF value somewhere after the dojocore has been loaded:

if(dojo.isMoz)
{
   dojo.isFF = parseFloat(navigator.userAgent.split("Firefox/")[1]) || parseFloat(navigator.userAgent.split("Iceweasel/")[1]) || 0;
}

In looking at ticket:3974, this workaround is an incorrect solution

Change History (5)

comment:1 Changed 11 years ago by bill

Milestone: tbdfuture
Summary: dijit.form.NumberTextBox does not render properly in IceweaselNumberTextBox: does not render properly in Iceweasel

Well, dijit doesn't support Iceweasel, just FF2 and FF3. I guess the text on http://dojotoolkit.org/support/faq/what-browsers-does-dojo-support is somewhat ambiguous but that's our policy.... I'm not sure if this ticket is really about Iceweasel or it's about FF on linux with the weird version string, as per #3974.

If you'd like to file a CLA and submit patches for Iceweasel we can probably integrate them. Perhaps it's just a question of changing dojo.isFF to dojo.isMoz in some places, but given that we are branching based on FF2 vs FF3 (specifically whether contentEditableDiv is available), it seems more complicated.

comment:2 Changed 11 years ago by bill

We changed a lot of isFF to isMoz for 1.3, is this working for you now?

comment:3 Changed 11 years ago by Jonathan Bowers

This now renders correctly in Iceweasel

comment:4 Changed 11 years ago by bill

Milestone: future1.3
Resolution: fixed
Status: newclosed

comment:5 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.