Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#7735 closed defect (fixed)

IE7: initial layout broken for slider scrolled out of view

Reported by: bill Owned by: Douglas Hays
Priority: high Milestone: 1.4
Component: Dijit - Form Version: 1.2beta
Keywords: Cc:
Blocked By: Blocking:

Description

See themeTester.html on IE7. Disabled sliders don't render properly

Related to #7371; perhaps getting rid of opacity settings will fix this problem too.

Resizing the TabContainer makes them render correctly.

Attachments (1)

slider.png (10.9 KB) - added by bill 11 years ago.

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by bill

Attachment: slider.png added

comment:1 Changed 11 years ago by dante

perhaps this is the same position:relative thing as slider in accordion was.

comment:2 Changed 11 years ago by Douglas Hays

Milestone: tbd1.3

Marking to 1.3 since it's not a regression.

comment:3 Changed 11 years ago by Douglas Hays

Milestone: 1.31.4

Deferred until afer IE8 support is added.

comment:4 Changed 11 years ago by bill

Milestone: 1.41.5

bumping 1.4 tickets to 1.5, and most 1.3 tickets to 1.4

comment:5 Changed 11 years ago by Douglas Hays

Milestone: 1.51.4

This appears to be an IE7-specific problem that has been fixed in IE8 (which has an unrelated problem with the vertical slider). This ticket may be related to #7733. We probably need a workaround for themetester.

comment:6 Changed 11 years ago by Douglas Hays

Summary: Slider: layout broken for disabled slider on IE7IE7: initial layout broken for slider scrolled out of view

not related to being disabled, but when initially rendered and scrolled out of view

comment:7 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [17349]) Fixes #7735. Add IE7 specific layout hack to get IE to rerender the slider when it first comes into view.

comment:8 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.