Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#7733 closed defect (fixed)

Spinner: layout problems on IE7

Reported by: bill Owned by: Douglas Hays
Priority: high Milestone: 1.4
Component: Dijit - Form Version: 1.2beta
Keywords: Cc:
Blocked By: Blocking:

Description

Spinner doesn't show up correctly on themeTester.html on IE7 until you focus it:

Note how the arrows for the disabled spinner are misplaced, and the arrows for enabled spinner are just invisible.

Attachments (2)

spinner.png (19.8 KB) - added by bill 11 years ago.
7733.html (851 bytes) - added by Douglas Hays 11 years ago.
Small testcase. Seems to be an IE7 bug with strict DOCTYPE that is fixed in IE8.

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by bill

Attachment: spinner.png added

comment:1 Changed 11 years ago by Douglas Hays

Milestone: tbd1.3

Marking to 1.3 since it's not a regression.

Changed 11 years ago by Douglas Hays

Attachment: 7733.html added

Small testcase. Seems to be an IE7 bug with strict DOCTYPE that is fixed in IE8.

comment:2 Changed 11 years ago by Douglas Hays

[15878] References #7733. Add themetester workaround to IE7 strict DOCTYPE bug where absolute positioning inside a scrollable DIV is incorrectly rendered. This appears to be fixed in IE8, and was not a problem in IE6.

comment:3 Changed 11 years ago by Douglas Hays

Milestone: 1.3future

Moving to future since an IE7 workaround has been identified. I could not come up with a corresponding change to the template that worked.

comment:4 Changed 11 years ago by Douglas Hays

Milestone: future1.4

Need to generalize the fix to #7735 to fix this as well.

comment:5 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

[17350] Fixes #7733. Remove previous workaround from themeTester.html. Moved the fix for #7735 to _FormValueWidget so that it can be called by any widget and added call to the new layout hack to both spinner and slider.

comment:6 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.