Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#7724 closed defect (fixed)

IE7 only: If a FilteringSelect is declared with <input dojoType ... /> instead of <div dojoType ... /> and has an onChange handler, onChange fires upon page load

Reported by: mog Owned by:
Priority: high Milestone: 1.2
Component: Dijit - Form Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

The attached HTML and JSON files reproduce this.

If test.html is loaded in Firefox, no alert boxes appear upon page load.

If test.html is loaded in IE7, the alert "FilteringSelect? input" appears.

Attachments (2)

test.html (1.6 KB) - added by mog 11 years ago.
data.json (114 bytes) - added by mog 11 years ago.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by mog

Attachment: test.html added

Changed 11 years ago by mog

Attachment: data.json added

comment:1 Changed 11 years ago by bill

Resolution: worksforme
Status: newclosed

Hmm, this is working fine for me, on IE7, against trunk. onChange is firing as soon as you blur a field, maybe that's your issue?

Originally I thought it was an issue the the /> to close tags, which is only valid in XHTML and even then not sure how well it works for <div>, but on second thought I guess that's not the issue.

comment:2 Changed 11 years ago by mog

Many thanks- confirmed works for me also when I update trunk. Apologies for false alarm...

comment:3 Changed 11 years ago by bill

Milestone: tbd1.2
Resolution: worksforme
Status: closedreopened
Version: 1.2beta1.1.1

No problem. I'm marking this as "fixed" in 1.2.

comment:4 Changed 11 years ago by bill

Resolution: fixed
Status: reopenedclosed

comment:5 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.