Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7722 closed defect (fixed)

defect: Axis2D error on null ticks

Reported by: SternJason Owned by: Eugene Lazutkin
Priority: high Milestone: 1.2.2
Component: Charting Version: 1.2beta
Keywords: charting axis2d null ticks Cc:
Blocked By: Blocking:

Description

Current, the Default.js file attempts to generate tick marks without first verifying that they have been defined. This causes problems when using multiple plots or when changing the name of the axises (hAxis, vAxis) as the ticks don't seem to be autogenerated.

I don't recall the actual line number, but the problem code starts with:

dojo.forEach(t.major,

and ends right before:

this.dirty=false;

Wrapping this code with a null check for t seems to fix the issue and allows for charts that don't have ticks and for autogenerated ticks based off of multiple (line) plots.

Thanks for all your hard work! Jason

Attachments (1)

test.html (2.1 KB) - added by SternJason 11 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 11 years ago by Eugene Lazutkin

Milestone: tbd

What you described is not a bug. t being null is. Would you mind to attach a minimalistic example that shows how you manage to do that?

comment:2 Changed 11 years ago by Eugene Lazutkin

Priority: highnormal
severity: majornormal

Changed 11 years ago by SternJason

Attachment: test.html added

comment:3 Changed 11 years ago by SternJason

Sure! I just uploaded a very simple sample (although my actual use is much more complex). The attached file should run without needing any additional resources as long as you update the script tag to point to your dojo 1.2rc1 instance.

Please note that if I add the null pointer check, the chart is displayed correctly with the correct axis labeling. Thanks! Jason

comment:4 Changed 11 years ago by Eugene Lazutkin

Milestone: tbdfuture
Status: newassigned

comment:5 Changed 11 years ago by Eugene Lazutkin

Milestone: future1.2.1

comment:6 Changed 11 years ago by Eugene Lazutkin

Resolution: fixed
Status: assignedclosed

The trac is broken. It doesn't show any changesets related to this ticket. Nevertheless, I close this ticket as fixed.

comment:7 Changed 11 years ago by Eugene Lazutkin

Relevant changeset: [15466].

comment:8 Changed 11 years ago by Eugene Lazutkin

#8014 is the dup of this ticket.

comment:9 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.2.11.2.2
Note: See TracTickets for help on using tickets.