Opened 11 years ago

Closed 11 years ago

#7705 closed defect (fixed)

[regression] InlineEditBox: loses focus after entering figure '9'

Reported by: toa Owned by: Douglas Hays
Priority: high Milestone: 1.2
Component: Dijit Version: 1.2beta
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Its a problem with the InlineEditBox. When I try to input figure '9' component loses focus.

Change History (4)

comment:1 Changed 11 years ago by bill

Component: GeneralDijit
Description: modified (diff)
Milestone: tbd1.2
Owner: anonymous deleted
Summary: InlineEditBox loses focus after entering figure '9'InlineEditBox: loses focus after entering figure '9'

Hmm, I tried this with the first InlineEditBox in test_InlineEditBox.html and it does reproduce. Very strange. Happened on FF3/mac and safari/mac, so presumably on other browsers too.

If you just click the first InlineEditBox on test_InlineEditBox.html and start typing numbers, when you enter 9 the edit is terminated and it goes back to view mode.

comment:2 Changed 11 years ago by bill

Owner: set to Douglas Hays

comment:3 Changed 11 years ago by Douglas Hays

severity: normalmajor
Summary: InlineEditBox: loses focus after entering figure '9'[regression] InlineEditBox: loses focus after entering figure '9'

regression caused by [13547]

comment:4 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [15312]) Fixes #7705 !strict. '9'==9 is true in javascript so I changed those occurrences to ===

Note: See TracTickets for help on using tickets.