Opened 11 years ago

Closed 10 years ago

#7675 closed defect (fixed)

DataGrid: keyboard navigation problems with key repeat

Reported by: Adam Peller Owned by: Bryan Forbes
Priority: high Milestone: 1.4
Component: DojoX Grid Version: 1.2beta
Keywords: a11y keyboard Cc: Joseph Scheuhammer, Becky Gibson
Blocked By: Blocking:

Description (last modified by Adam Peller)

press an arrow key and the selection moves as expected. Hold down an arrow key (e.g. down) and the grid scrolls without changing its selection. The current selection ends up off screen. Hit an arrow key once, and the grid will scroll back to where you were before.

Change History (7)

comment:1 Changed 11 years ago by Adam Peller

Cc: Becky Gibson added
Description: modified (diff)

comment:2 Changed 11 years ago by Adam Peller

Keywords: a11y keyboard added

comment:3 Changed 11 years ago by bill

Milestone: tbd1.3

marking these TBD tickets for 1.3 for now, although Bryan may recategorize

comment:4 Changed 11 years ago by Becky Gibson

is this a duplicate of #7286?

comment:5 Changed 10 years ago by Bryan Forbes

Milestone: 1.3future

comment:6 Changed 10 years ago by Bryan Forbes

Milestone: future1.4

The grid needs to do keyboard handling with onKeyPress. This should go in for 1.4.

comment:7 Changed 10 years ago by Nathan Toone

Resolution: fixed
Status: newclosed

Fixed in 1.4, at least.

Note: See TracTickets for help on using tickets.