Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7674 closed defect (fixed)

DataGrid: selection difficult to see in test_edit_dijit.html

Reported by: Adam Peller Owned by: nonken
Priority: high Milestone: 1.2
Component: DojoX Grid Version: 1.2beta
Keywords: a11y keyboard Cc: Joseph Scheuhammer, nonken, Becky Gibson
Blocked By: Blocking:

Description

Unlike the other tests, the current selection is just a dotted line, not a heavy dash line, and it's very hard to see.

Change History (11)

comment:1 Changed 11 years ago by Adam Peller

Cc: Becky Gibson added

comment:2 Changed 11 years ago by Adam Peller

note, in the other tests, when you mouse over the selected cell, it uses a different style to show the selection which I think is also hard to see. Perhaps that's a different issue.

comment:3 Changed 11 years ago by Adam Peller

Keywords: a11y keyboard added

comment:4 Changed 11 years ago by Becky Gibson

the border is visible in test_grid.html - it is a blue dash for selected and a dotted green for mouse over. BUT, in test_grid.html there is no class="tundra" on the body tag. Thus, we need to updated the grid mouseover and selection styles for tundra. Not sure what to use to make visible, though. We could use different background colors in tundra and borders in dijit_a11y.

comment:5 Changed 11 years ago by Becky Gibson

(In [15265]) refs #7674 update test files that included tundra css files to have class="tundra" on body tag. Updated test_keyboard and test_grid_tooltip_menu to use tundra theme since these are important for keyboard testing.

comment:6 Changed 11 years ago by bill

Milestone: tbd1.3

marking these TBD tickets for 1.3 for now, although Bryan may recategorize

comment:7 Changed 11 years ago by Adam Peller

Milestone: 1.3tbd
Owner: changed from Bryan Forbes to nonken
Priority: normalhigh

comment:8 Changed 11 years ago by bill

The issue isn't so much dotted vs. dashed as the color. If you change tundraGrid.css like this it works well:

.tundra .dojoxGridCellFocus {
	border: 1px dashed darkblue;
}

and

.tundra .dojoxGridCellFocus.dojoxGridCellOver {
	border: 1px dashed darkblue;
}

then it's pretty visible.

comment:9 Changed 11 years ago by bill

Resolution: fixed
Status: newclosed

(In [15286]) Fixes #7674: DataGrid?: selection difficult to see in test_edit_dijit.html Nonken can tweak these setting if he likes, of course.

comment:10 Changed 11 years ago by bill

Milestone: tbd1.2

comment:11 Changed 11 years ago by Adam Peller

(In [15288]) One more dashed reference in the base css. Fixes #7674 And remove a negative x placement. Refs #7679

Note: See TracTickets for help on using tickets.