Opened 11 years ago

Closed 10 years ago

#7653 closed enhancement (invalid)

dojox-widget-colorpicker onchange event does not always return the correct color

Reported by: ngduonglam Owned by: dante
Priority: high Milestone: future
Component: DojoX Widgets Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

dojox-widget-colorpicker onchange event does not always return the correct color; and this happened when user drag from the vertical bar, and then select a color. The HexValue? is changes, and corrected; but the onchange event was not fired, and user got the wrong color.

This can be workaround by set showHex="true", and instead of handle the onchange event, just use HexValue? directly. But it's not user friendly for normal user, which don't know anything about Hex value.

Thanks, Lam Nguyen

Change History (2)

comment:1 Changed 11 years ago by dante

Milestone: tbdfuture

I'm not seeing this behavior in nightly. would you please attach a test case. Is this limited to showHex="false" explicitly, I see the test case doesn't cover that (all the examples show hex values, and seem to be in sync with cursor positions)

comment:2 Changed 10 years ago by dante

Resolution: invalid
Status: newclosed

closing because I cannot reproduce. please reopen with test case attached.

Note: See TracTickets for help on using tickets.