Opened 11 years ago

Closed 11 years ago

#7640 closed defect (fixed)

[patch][ccla]editor: [regression] can't shift-tab back into the editor in IE7

Reported by: Becky Gibson Owned by: Becky Gibson
Priority: high Milestone: 1.2
Component: Dijit Version: 1.2beta
Keywords: Cc:
Blocked By: Blocking:

Description

load dijit/tests/test_Editor.html. Click in any of the editor examples on the page to put focus into the editor. Press tab to move focus out of the editor then press shift-tab to put focus back into the editor - IE 7 gives an error.

I can't reproduce this in FF (tested FF3 on Win and Mac) but there is tab handling code for FF since it does not allow tabbing out of the editor by default.

Attachments (1)

4607and7640.patch (4.9 KB) - added by Becky Gibson 11 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by Becky Gibson

Priority: normalhigh

I did some console.log debugging and the problem is either in _moveToBookmark call to dojo.withGlobal(this.window,'moveToBookmark',dijit,[bookmark]); or is a problem in _saveSelectiion()

comment:2 Changed 11 years ago by Becky Gibson

Milestone: tbd1.2
Summary: editor: can't shift-tab back into the editor in IE7editor: [regression] can't shift-tab back into the editor in IE7

Changed 11 years ago by Becky Gibson

Attachment: 4607and7640.patch added

comment:3 Changed 11 years ago by Becky Gibson

in 4607and7640.patch - removed the _savedSelection added in richtext for use in focus and blur events as it seemed to conflict with savedSelecton and saveSelection in editor . Added missing return in queryCommandValue(). Also modified onkeydown handlers to support tabIndent in "backported" editor.

comment:4 Changed 11 years ago by Adam Peller

Summary: editor: [regression] can't shift-tab back into the editor in IE7[patch][ccla]editor: [regression] can't shift-tab back into the editor in IE7

comment:5 Changed 11 years ago by bill

Owner: set to Becky Gibson

comment:6 Changed 11 years ago by Becky Gibson

Resolution: fixed
Status: newclosed

(In [15282]) fixes #4607 #7640 removed code that was setting selection in richtext focus/blur that was added during refactor and was causing focus problems in IE. Fixed onkeydown handlers in editor and richtext - there was duplicate tab handling code after the "backport" of the editor back to 1.1.1.

Note: See TracTickets for help on using tickets.