Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#7637 closed defect (duplicate)

With MSIE6/7, attempts to sort a DataGrid instance cause the grid body to collapse

Reported by: enzo Owned by: anonymous
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.2beta
Keywords: Cc:
Blocked By: Blocking:

Description

This can be readily checked with the examples at http://docs.dojocampus.org/dojox/grid . It only happens with Dojo 1.2b1 and with MSIE 6 or 7; with FF3, and/or the DataGrid? implementation in the Nightly Build of 19 Jul 2008, the behaviour is correct.

Inspecting the DOM through the "Debugbar" debugger (www.debugbar.com) I noticed that after the collapse of the grid the style of one of the component DOM elements, with class dojoxGridContent, has "HEIGHT: 0px":

<DIV class=dojoxGridContent hideFocus style="WIDTH: 379px; HEIGHT: 0px" _zipIdx="57" dojoAttachPoint="contentNode" unselectable="on">

I'm also attaching a single-file testcase, built with some modifications from one of the examples at DojoCampus?.

Attachments (1)

testGrid1.2.html (2.2 KB) - added by enzo 11 years ago.
Test case for grid collapse upon sort with MSIE6/7 and Dojo 1.2b1

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by enzo

Attachment: testGrid1.2.html added

Test case for grid collapse upon sort with MSIE6/7 and Dojo 1.2b1

comment:1 Changed 11 years ago by Nathan Toone

Resolution: duplicate
Status: newclosed

Dupe of #7554

comment:2 Changed 11 years ago by bill

Component: GeneralDojoX Grid
Note: See TracTickets for help on using tickets.