Opened 11 years ago

Closed 11 years ago

#7635 closed defect (invalid)

*.layout.ContentPane .aspx target on IE6

Reported by: stephan Owned by: anonymous
Priority: high Milestone: tbd
Component: Dijit Version: 1.2beta
Keywords: Cc:
Blocked By: Blocking:

Description

Hi, I have a problem setting hRef property of a dijit.layout.ContentPane? to .aspx target on IE6. In generall it works fine, but on IE6 (in my case win2k) the pane content shows the text undefined after loading. I have tried to set the static HTML property href and set the href by Javascriptcode using the setHRef function. I see things in context with ASP.NET. Because pane text is "undefined" when I set href to a dynamic .aspx. Setting href to static .htm or .html file will work in IE6. All other browsers are working with .aspx files

How ever the same problem exists for dojo.widget.TabContainer?, dojo.widget.Accordion and the dialog widget.

I have also tried to set the enableViewState of my aspx page to false. Im not sure but i mean if i remove the [form id="unique_form_id" runat="server"][form] element from html code it works. But if I do that I can not render dynamic HTML code :( ...

I#ve tried to use the dojox.layout.ContentPane?, but it is the same behavior. I've also hooked the onLoad, onError and onDownloadError event. In Error event i can catch the normal page content. So how it should displayed in contentPane. I think it is not the usual way to use setConent for pane via onError event :( ...

I#m using DOJO 1.1.1.

Change History (3)

comment:1 Changed 11 years ago by bill

Component: GeneralDijit
Resolution: invalid
Status: newclosed

Sorry things aren't working for you, but we can't do anything w/out a test case. The ASPX target is likely unrelated. Remember that ASPX is converted to HTML on the server and sent to the client, so it's presumably unrelated to whatever your issue is.

You might try some tracing code like firebug or fiddler to see what the server is returning. Likely it's not returning any data. No idea why IE6 only is broken though.

If you can make a reproducible test case for this (just using plain HTML, not ASPX) then please attach the file and reopen this ticket.

comment:2 Changed 11 years ago by youngho

Resolution: invalid
Status: closedreopened

Hello,

You can reproduce with dijit/tests/layout/test_StackContainer.html

Add href property like <p id="page2" dojoType="dijit.layout.ContentPane?" title="page 2" href="_lorem.html">

FF2 works fine, IE6 fail.

Thanks,

comment:3 Changed 11 years ago by bill

Resolution: invalid
Status: reopenedclosed

Ah, yes that's because you are nesting a <p> inside of another <p>, which is illegal HTML. The first <p> is in test_StackContainer.html (the code you wrote above) and the second is in _lorem.html.

Note: See TracTickets for help on using tickets.