Opened 11 years ago

Closed 11 years ago

#7614 closed defect (fixed)

mail demo fails creating editor in contentpane

Reported by: dante Owned by: Douglas Hays
Priority: high Milestone: 1.2
Component: Editor Version: 1.2beta
Keywords: Cc: bill, liucougar
Blocked By: Blocking:

Description

the nightly version of the mail demo dies in FF3 (and reportedly in IE7) when creating the ContentPane with the href="" editor with:

'contentDoc is undefined'

http://archive.dojotoolkit.org/nightly/checkout/demos/mail/demo.html

Attachments (1)

7614.patch (509 bytes) - added by Douglas Hays 11 years ago.
Forces IE7 to follow an existing IE6 path

Download all attachments as: .zip

Change History (10)

comment:1 Changed 11 years ago by bill

Component: GeneralEditor
Milestone: tbd1.2
Owner: changed from anonymous to Douglas Hays

Perhaps related to [14417]. Doug, looks like you didn't merge this change after the refactor?

comment:2 Changed 11 years ago by Adam Peller

Priority: normalhigh

comment:3 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [15173]) Fixes #7614. References #7097. Remerge Editor change from [14417].

comment:4 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: closedreopened

comment:5 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: reopenedclosed

(In [15195]) Fixes #7614. References #7097. Remerge Editor change from [14499].

comment:6 Changed 11 years ago by dante

Resolution: fixed
Status: closedreopened

still b0rken in ie7

comment:7 Changed 11 years ago by Douglas Hays

Cc: bill liucougar added

This defect is unrelated to the Editor remerge. It looks like a new timing problem. Accessing iframe.contentWindow in IE7 is throwing an error since its apparently not yet setup completely. Attaching a possible patch but its needs careful review since this is outside my comfort zone.

Changed 11 years ago by Douglas Hays

Attachment: 7614.patch added

Forces IE7 to follow an existing IE6 path

comment:8 Changed 11 years ago by bill

Looks good to me but I can't reproduce the error (with or w/out your patch)... I guess that's the nature of race conditions. If it fixes the problem I'd say to check it in.

comment:9 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: reopenedclosed

(In [15236]) Fixes #7614. Accessing iframe.contentWindow too early was throwing an Unspecified exception. Used the IE6 code path to delay until the iframe is fully initialized.

Note: See TracTickets for help on using tickets.