Opened 11 years ago

Closed 11 years ago

#7607 closed defect (fixed)

Abbreviation no longer working for dijit Calendar

Reported by: rovon Owned by: Adam Peller
Priority: high Milestone: 1.2
Component: General Version: 1.2beta
Keywords: Cc: hwcdl@…
Blocked By: Blocking:

Description

Defining a new instance of a dijit _Calendar no longer works when using the following tag: dayWidth: "abbr",

And now displays the same full day labels as: dayWidth: "wide",

The problem seems to be in a change to \dojo\cldr\nls\en\gregorian.js

Attachments (1)

alias-issue-7607.patch (38.0 KB) - added by Adam Peller 11 years ago.
from Evan Huang, IBM (CCLA) calculates aliases with overrides taken into consideration, also removes alias cruft when done.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 11 years ago by Adam Peller

Owner: changed from anonymous to Adam Peller

comment:2 Changed 11 years ago by Adam Peller

Cc: hwcdl@… added
Milestone: tbd1.2
Priority: normalhigh

Looks like a regression (refs #7188) The alias in root seems to be getting used, even though it's overridden by the en locale in LDML

Changed 11 years ago by Adam Peller

Attachment: alias-issue-7607.patch added

from Evan Huang, IBM (CCLA) calculates aliases with overrides taken into consideration, also removes alias cruft when done.

comment:3 Changed 11 years ago by Adam Peller

(In [15204]) Another stab at chasing XML aliases. Seems to preserve the abbreviated variants this time. Refs #7607. Thanks, Evan.

comment:4 Changed 11 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [15205]) Update dojo.cldr with proper aliasing to preserve abbreviations. Fixes #7607

Note: See TracTickets for help on using tickets.