Opened 11 years ago

Closed 11 years ago

#7604 closed defect (fixed)

Firebug Lite doesn't work when djConfig.popup == true

Reported by: mrblakwell Owned by: dante
Priority: high Milestone: 1.2
Component: Core Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description

i set debug: true and popup: true in my djConfig attribute on my script tag, and when the firebug window opens, it just has a black background and nothing happens.

unfortunately, i couldn't debug this in firebug :(

but the problem stems from this line in the createFrame method:

djConfig.debugContainerId = 'fb';

at this point, it should be

dojo.config.debugContainerId = 'fb';

Change History (3)

comment:1 Changed 11 years ago by mrblakwell

ok, turns out it's caused by my djConfig being in my script tag

if djConfig isn't declared as a global before grabbing dojo.js, then dojo never makes it a global.

phiggins said he'd fix this...

comment:2 Changed 11 years ago by dante

Milestone: tbd1.2
Owner: changed from anonymous to dante
Status: newassigned
Version: 1.2beta1.1.0

comment:3 Changed 11 years ago by dante

Resolution: fixed
Status: assignedclosed

(In [15143]) fixes #7604 - can't rely on djConfig being global, need to use dojo.config - which handles scopeName, and djConfig="" on the <script> tag, and conversion from a global djConfig !strict

Note: See TracTickets for help on using tickets.