Opened 11 years ago

Closed 10 years ago

#7599 closed defect (fixed)

Bug in Editor inside contentPane in FF3

Reported by: taras Owned by: Jared Jurkiewicz
Priority: high Milestone: 1.3
Component: Editor Version: 1.2beta
Keywords: refactor Cc:
Blocked By: Blocking:

Description (last modified by bill)

Hi

Editor seems not to receive any key/mouse events if inside a contentPane inside a dialog. Text cannot be seen, too.

This problem seems to be similar to the bug number: #7408 corrected by Bill.

I can see the problem only inside FF3. In the following browsers everything it is OK: FF2, IE7, Safari3.

See the attached test and do:

[1] click on the button.

--> a dialog will appear with an editor inside.

[2] move the dialog slowly and cross the division between both contentpane (splitter)

--> Text will appear !!

ps: I attached also two pictures before and after the moving of the dialog.

thanks

Eduardo

Attachments (3)

1.gif (10.4 KB) - added by taras 11 years ago.
Before moving
2.gif (11.7 KB) - added by taras 11 years ago.
After Moving
dialogEditor.html (2.4 KB) - added by taras 11 years ago.

Download all attachments as: .zip

Change History (13)

Changed 11 years ago by taras

Attachment: 1.gif added

Before moving

Changed 11 years ago by taras

Attachment: 2.gif added

After Moving

Changed 11 years ago by taras

Attachment: dialogEditor.html added

comment:1 Changed 11 years ago by bill

Description: modified (diff)

Hmm, that's a strange one. I can reproduce on FF3 on windows although not on mac.

Apparently something to do with that center div of the BorderContainer?, perhaps confusion because it has top/left/bottom/right all specified?

comment:2 Changed 11 years ago by bill

Component: DijitDojoX Editor
Milestone: tbd1.3
Owner: set to alex

Well, this is fixed by the editor refactor; you can see it working if you change your test file to use dojox.editor.Editor.

Marking for that milestone (for when dojox.editor.Editor is finished and moved back into dijit).

comment:3 Changed 11 years ago by taras

Yes, very impressive widget.I will use it. For the functionalty I need now it OK++ (of course because it is dojox, I will pray every night that at least what is working will continue to work ...)

Will dojox.editor.Editor replace the dijit.editor in 1.3 ?

thanks Bill.

comment:4 Changed 11 years ago by bill

That's the plan.

comment:5 Changed 11 years ago by taras

This bug is a malfunction of dijit.editor and in my opinion should be corrected before 1.2 is released.

dojox.editor was removed from the toolkit, so the importance of this correction is much critical.

thanks

comment:6 Changed 11 years ago by Adam Peller

Component: DojoX EditorEditor
Keywords: refactor added
Owner: changed from alex to liucougar

comment:7 Changed 11 years ago by bill

Milestone: 1.3future

comment:8 Changed 10 years ago by bill

Owner: liucougar deleted

comment:9 Changed 10 years ago by Jared Jurkiewicz

Owner: set to Jared Jurkiewicz

I think this problem is fixed. I cannot reproduce it in trunk (1.5). It's working great. I think all the editor init cleanup in 1.3, 1.4 and 1.5 fixed it. Looks fine in all those releases in FF 3.5 (Will check FF 3.0 soon)

comment:10 Changed 10 years ago by Jared Jurkiewicz

Milestone: future1.3
Resolution: fixed
Status: newclosed

This appears fixed in 1.3+. I cannot reproduce the reported issue anymore. The refactor of editor init likely resolved it. Closing as fixed.

Note: See TracTickets for help on using tickets.