Opened 11 years ago

Closed 11 years ago

#7586 closed defect (fixed)

editor: information about the editor is not announced by the screen reader in Firefox3

Reported by: Becky Gibson Owned by: Becky Gibson
Priority: high Milestone: 1.2
Component: Accessibility Version: 1.1.1
Keywords: Cc: davidb
Blocked By: Blocking:

Description

This is a side effect of going back to the version of the editor based on an iframe for the 1.2. release. Firefox 3 now supports ARIA roles and properties on an iframe element so the original implementation which works in Firefox 2 no longer works in Firefox 3.

The problem is that when a user has focus an presses the tab key to get out of the editing area, the code catches the tab key and puts focus on the actual iframe. In Firefox 2, the screen reader will announce the editor label + "edit area frame" so a screen reader user knows where the focus is. This is no longer happening in Firefox 3 and the screen reader has no idea where focus has gone.

Change History (1)

comment:1 Changed 11 years ago by Becky Gibson

Resolution: fixed
Status: newclosed

(In [15114]) fixes #7586 For FF3 need to set the title on the iframe and in FF2 set the title on iframe.contentDocument in order for it to be properly exposed to the screen reader.

Note: See TracTickets for help on using tickets.