Opened 11 years ago

Closed 9 years ago

#7583 closed defect (fixed)

BorderContainer: focus on splitters is not visible in Firefox

Reported by: Becky Gibson Owned by: Becky Gibson
Priority: low Milestone: 1.5
Component: Accessibility Version: 1.1.1
Keywords: Cc: Sam Foster, nonken
Blocked By: Blocking:

Description

This was found in 1.2b1 as well as 09/02/08 nightly. Resizable splitters are in the tab order and get focus so the user can adjust the size of a pane via the arrow keys (although resizing is currently broken #7582). In Firefox 3 focus on the splitters is barely noticeable - it can only be seen on the very edges of the splitter. In high contrast mode focus can not be seen at all. This worked properly in 1.1 in Firefox 2 & 3 as well as IE (see http://download.dojotoolkit.org/release-1.1.1/dojo-release-1.1.1/dijit/tests/layout/test_BorderContainer.html). The problem currently only exists in Firefox 2&3, IE 7 is still fine.

Focus on the splitters needs to be visible in standard as well as Windows high contrast mode.

Attachments (1)

7583.patch (385 bytes) - added by Becky Gibson 9 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 11 years ago by bill

Summary: borderContainer: focus on splitters is not visible in Firefox[regression] BorderContainer: focus on splitters is not visible in Firefox

comment:2 Changed 11 years ago by Adam Peller

Cc: nonken added

comment:3 Changed 11 years ago by Adam Peller

Owner: changed from Adam Peller to nonken

comment:4 Changed 11 years ago by nonken

Resolution: fixed
Status: newclosed

(In [15206]) Changed z-index of splitter to bring back border on focus, fixes #7583

comment:5 Changed 10 years ago by bill

Hmm, this presumably negates the effects of [14392] and causes #6438 to occur.

comment:6 Changed 10 years ago by bill

(In [16064]) Give splitters a high z-index on FF, low on IE, so that FF correctly shows splitter focus, but that on IE the splitters don't cover up the borders of panes.

Also fixes problem seen in themeTester.html (non-active sizing) where the splitter being dragged appears behind the stationary splitters.

ISTM that FF/high-contrast focus on splitters is still very difficult to see though, both before and after this change.

Refs #6438, #7583.

comment:7 Changed 10 years ago by bill

Priority: highestlow
Summary: [regression] BorderContainer: focus on splitters is not visible in FirefoxBorderContainer: focus on splitters is not visible in Firefox

Reopening this ticket since focus on firefox in high-contrast mode is still near impossible to see. Only the "short" ends of the splitter have the dotted border.

comment:8 Changed 10 years ago by Adam Peller

Resolution: fixed
Status: closedreopened

comment:9 Changed 10 years ago by nonken

Milestone: 1.21.4

comment:10 Changed 10 years ago by bill

Milestone: 1.41.5

comment:11 Changed 9 years ago by Becky Gibson

Milestone: 1.51.5.1
Owner: changed from nonken to Becky Gibson
Status: reopenednew

Changed 9 years ago by Becky Gibson

Attachment: 7583.patch added

comment:12 Changed 9 years ago by bill

Milestone: 1.5.11.5

Patch looks good to me, surely it won't break anything.

comment:13 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

From Becky's check in:

(In [22359]) fixes #7583 create a class to make high contrast focus on border container splitters visible in FF

Note: See TracTickets for help on using tickets.