Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#758 closed defect (fixed)

xdomain loading of widget that uses href attribute does not work with widgets in the href content.

Reported by: James Burke Owned by: James Burke
Priority: high Milestone:
Component: Widgets Version: 0.2
Keywords: xdomain widget href Cc:
Blocked By: Blocking:

Description

This test case reproduces the issue:

tests/xdomain/test_xdomainTooltip.html

The tooltip has a href="doc0.html" attribute. When doc0.html is brought in, it has markup for a combo box and and a button. It has a script block that does a dojo.require() for these widgets.

The asynchronous xd loading means that the widget parsing for doc0.html cannot be executed immediately. It would be good to register a dojo.addOnLoad() call before proceeding with the parsing (this will also work for non-xd dojo installs).

It looks like maybe the fix should be placed somewhere in src/widget/html/ContentPane.js (maybe somewhere in splitAndFixPaths?)

I would like some guidance on if this is the right place to put the fix, and if this is a 0.3.1 or 0.4 issue.

Change History (3)

comment:1 Changed 13 years ago by James Burke

Milestone: 0.3.1
Owner: changed from anonymous to James Burke
Status: newassigned

comment:2 Changed 13 years ago by James Burke

Resolution: fixed
Status: assignedclosed

Fixed. Thanks to Bill for guidance and for Fredrik for making the ContentPane? changes to support xdomain.

comment:3 Changed 12 years ago by (none)

Milestone: 0.3.1

Milestone 0.3.1 deleted

Note: See TracTickets for help on using tickets.