Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7574 closed defect (fixed)

[regression] TitlePane: +/- text equivalents for arrows too small to see in high contrast mode

Reported by: Becky Gibson Owned by: Becky Gibson
Priority: high Milestone: 1.2
Component: Accessibility Version: 1.1.1
Keywords: Cc: Sam Foster
Blocked By: Blocking:

Description (last modified by Becky Gibson)

The arrow icons in the title pane title bar are replaced by + and - characters in high contrast mode but they are too small too be distinguished. I suspect that someone has changed the CSS to assign the font size as 1 px but haven't tracked it down, yet. This is an a11y failure and needs to be fixed. Found in Sept. 02, 2008 nightly (release 1.20b1)

Change History (4)

comment:1 Changed 11 years ago by Becky Gibson

Description: modified (diff)

comment:2 Changed 11 years ago by bill

Summary: titlepane: +/- text equivalents for arrows too small to see in high contrast mode[regression] TitlePane: +/- text equivalents for arrows too small to see in high contrast mode

comment:3 Changed 11 years ago by Becky Gibson

Resolution: fixed
Status: newclosed

(In [15147]) fixes #7574 use img element for icon so span for text equivalent no longer needs to be nested within icon element

comment:4 Changed 11 years ago by bill

(In [15149]) Minor CSS tweaking:

  • vertical-align: middle on text and icon makes them both vertically aligned (and aligned with each other) and removes need for some padding/margin adjustments
  • dijitInline not needed on images (they are inline-block by default)
  • font-size: 1px hack not needed for images since they can't contain text

Refs #7574

Note: See TracTickets for help on using tickets.