Opened 11 years ago

Closed 11 years ago

#7554 closed defect (fixed)

Dojox.DataGrid hides Rows when a Column Heading is clicked on IE7

Reported by: vlad Owned by: Nathan Toone
Priority: high Milestone: 1.2
Component: DojoX Grid Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

It is very easy to reproduce with Dojo tests. It appears to happen when the number of rows to display in the grid is small enough that they fit into a screen without scroll bars.. It only happens on IE7 (Opera 9.2, Fiire fox 3.1, Safari (windows version) -- work fine.

To reproduce

Open file \dojox\grid\tests\support\test_data.js change var rows = 100; to var rows = 5;

Run dojox\grid\tests\test_edit_canEdit.html using IE7 on windows XP (32 bit)

Click on any column heading -- observe that the rows are lost and only Column Headings are displayed

Change History (6)

comment:1 Changed 11 years ago by bill

Component: GeneralDojoX Grid
Owner: changed from anonymous to Bryan Forbes

comment:2 Changed 11 years ago by Bryan Forbes

Milestone: tbd1.2
Priority: normalhigh

comment:3 Changed 11 years ago by Bryan Forbes

Owner: changed from Bryan Forbes to Nathan Toone

comment:4 Changed 11 years ago by Nathan Toone

Resolution: fixed
Status: newclosed

(In [15100]) Fixes #7554 - height is mis-calculated in IE because hasLayout is true - so if we have no content, return 0 (for empty height) !strict

comment:5 Changed 11 years ago by enzo

Resolution: fixed
Status: closedreopened

It doesn't look fixed to me in 1.2b1: see #7637. But it was fixed in the Nightly Build of the 15th of July... Now it's baaaack!

comment:6 Changed 11 years ago by Nathan Toone

Resolution: fixed
Status: reopenedclosed

Please try again with a more recent nightly (post revision [15100]) - or wait for b2. This fix went in *after* b1 was released.

Note: See TracTickets for help on using tickets.