Opened 11 years ago

Closed 11 years ago

#7543 closed defect (invalid)

Using word 'multiple' for an attribute causes problems in IE7 (CheckedMultiSelect)

Reported by: vlad Owned by: dante
Priority: high Milestone: tbd
Component: DojoX Form Version: 1.1.1
Keywords: multiple, dojox.form.CheckedMultiSelect Cc:
Blocked By: Blocking:

Description (last modified by bill)

When using CheckedMultiSelect? and setting 'multiple' attribute to anything, the control always thinks it is set to 'true', on IE7

Safari, Firefox and even Opera do not report this problem (even though there are some visual problems with CheckedMultiSelect? on Opera).

I suspect that 'multiple' is a keyword somewhere in IE7 and possibly above, there in general in dojo using this keyword as an attribute probably would not work for testing if this attribute is 'true' -- because it will be most of the time on IE7.

For example

<select id="sel3_p4_id" dojoType="dojox.form.CheckedMultiSelect" multiple='XYZ'> 
<option value="FR">France</option>
<option value="BEL">Belarus</option>
</select>

would show as 'checkboxes' and not radio buttons

the same would be if multiple='false'

Change History (1)

comment:1 Changed 11 years ago by bill

Description: modified (diff)
Resolution: invalid
Status: newclosed

Multiple, like checked and disabled, are boolean attributes according to the browser. The correct syntax is:

<select id="sel3_p4_id" dojoType="dojox.form.CheckedMultiSelect" multiple> 
<option value="FR">France</option>
<option value="BEL">Belarus</option>
</select>

This is not a bug, it's how the parser and HTML works.

Note: See TracTickets for help on using tickets.