Opened 11 years ago

Closed 10 years ago

#7502 closed defect (worksforme)

Grid incorrectly renders when scrolled in complex layout.

Reported by: taroth Owned by: Nathan Toone
Priority: high Milestone: future
Component: DojoX Grid Version: 1.1.1
Keywords: Cc: taroth@…
Blocked By: Blocking:

Description

Version: svn trunk rev 14933 Browser: FF2 Platform: Linux (Ubuntu Gutsy) Errors: None

With a complex layout, BorderContainer?->TabContainer?->BorderContainer?->grid, when scrolling the grid leaves artefacts from the surrounding containers in the grid area. Moving the mouse over the artefacts clears them. Also, moving focus to another application clears the artefacts.

Attached is a simple test case and a screen shot of the problem.

Attachments (3)

grid-rendering-error-ff2.png (87.0 KB) - added by taroth 11 years ago.
example-ff3.png (102.0 KB) - added by taroth 11 years ago.
test_grid_in_tab.html (3.4 KB) - added by taroth 11 years ago.

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by taroth

comment:1 Changed 11 years ago by taroth

Looking at this again, it appears that the grid sizing is not correctly calculated and is not being recalculated as the grid's container is resized.

I have updated the test html file to have a moveable splitter which makes it a little easier to see the problem.

I've also added a screen shot showing the problem in FF3 and with firebug displaying the style.

Latest test is with svn version 15141.

Changed 11 years ago by taroth

Attachment: example-ff3.png added

Changed 11 years ago by taroth

Attachment: test_grid_in_tab.html added

comment:2 Changed 11 years ago by bill

Milestone: tbd1.3

marking these TBD tickets for 1.3 for now, although Bryan may recategorize

comment:3 Changed 11 years ago by Nathan Toone

Owner: changed from Bryan Forbes to Nathan Toone

Reassigning to me

comment:4 Changed 10 years ago by Nathan Toone

Milestone: 1.3future

comment:5 Changed 10 years ago by Nathan Toone

Resolution: fixed
Status: newclosed

I believe that this issue has been fixed. There were issues with the grid resizing within a content pane that have been resolved.

I am unable to reproduce with your attached test case.

comment:6 Changed 10 years ago by Adam Peller

Resolution: fixed
Status: closedreopened

comment:7 Changed 10 years ago by Adam Peller

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.