Opened 11 years ago

Closed 11 years ago

#7497 closed enhancement (duplicate)

json-comment-optional support in dojo.io.iframe.send()

Reported by: Josh Trutwin Owned by: James Burke
Priority: high Milestone: tbd
Component: IO Version: 1.1.1
Keywords: dojo.io.iframe.send handleAs json comment Cc:
Blocked By: Blocking:

Description

Would it be possible for dojo.io.iframe.send() to support the same handleAs params as dojo.xhrGet/Post/etc?

The values supported by iframe.send() are:

text, html, javascript, json

The values supported by xhrArgs:

text, json, json-comment-optional, json-comment-filtered, javascript, xml.

In particular the additional json options would be nice (json-comment-optional, json-comment-filtered) - unless these are going away?

Change History (1)

comment:1 Changed 11 years ago by James Burke

Resolution: duplicate
Status: newclosed

Tom Trenka added xml support for Dojo 1.2, see ticket #6334.

As for the json commented, they are deprecated in 1.2 (still available, but discouraged) so we will not add them to dojo.io.iframe.

But normally, each IO transport has different constraints, like dojo.io.iframe needing an HTML document with a PRE inside it for json and text returns -- maybe we can revisit to see if Safari 3 works differently now. But the bigger point is that it will be difficult to get the same handleAs parameters working across all transports -- they each have specific weaknesses or hacks that normally require specific server responses.

But hopefully Tom's addition of XML for dojo.io.iframe() is good enough for this ticket. Marking it as a dupe of #6334.

Note: See TracTickets for help on using tickets.