Opened 11 years ago

Closed 9 years ago

#7484 closed enhancement (fixed)

Grid support for standard keyboard selection and navigation

Reported by: David Schwartz Owned by: evan
Priority: high Milestone: 1.6
Component: DojoX Grid Version: 1.1.1
Keywords: 14open Cc:
Blocked By: Blocking:

Description

The standard Windows keyboard techniques for navigation and selection of objects within a container should be implemented by Grid. Mimic Windows Explorer behavior re effects of Up/Dn? (focus moves to previous/next objects, respectively), CTRL+Up/Dn? (leave selection and move input focus), ENTER (default action, e.g Open), CTRL+click (toggle selected state of object clicked), SPACEBAR (selects object with input focus), SHIFT+ Up/Dn? (extend selection), etc. This will allow keyboard users to apply the same techniques regardless of context, desktop or Web applications.

Change History (23)

comment:1 Changed 11 years ago by bill

Component: Dijit - LnFDojoX Grid
Resolution: duplicate
Status: newclosed

Looks like a dup of #7286.

BTW grid bugs are filed with component "DojoX Grid" since grid isn't part of dijit (yet).

comment:2 Changed 11 years ago by David Schwartz

Resolution: duplicate
Status: closedreopened

I read #7286. It's not a dupe of this ticket. That ticket addresses a problem when navigating too quickly with cursor keys. This ticket is about full support of keyboard navigation and selection including augmenter keys, e.g., CTRL.

Re-categorized component is fine

comment:4 Changed 11 years ago by Bryan Forbes

Milestone: tbd1.2
Owner: set to Bryan Forbes

comment:5 Changed 11 years ago by Becky Gibson

Keywords: a11y added

comment:6 Changed 11 years ago by bill

Milestone: 1.21.3

comment:7 Changed 11 years ago by Bryan Forbes

Milestone: 1.31.2

comment:8 Changed 11 years ago by Bryan Forbes

Milestone: 1.21.3

comment:9 Changed 11 years ago by Becky Gibson

Note that selection must be visible in Windows high contrast mode as well.

comment:10 Changed 11 years ago by David Schwartz

  • I assume that SPACE selects the cell currently with the focus?
  • Are tabs consumed by input fields and text areas? If so, how does the user tab out? CTRL+Tab and SHIFT+CTRL+Tab?
  • RE the following statement: Why would it take the focus on the first cell in the table? Is that what is intended?

"Once the focus is on the grid itself, any left, right, up, or down key takes the navigation focus to the position 1,1 in the grid regardless it is a simple or complex, unified or non-unified grid."

  • What is the effect of CTRL + Home/END in Actionable mode? I would think it would move the focus to the first/last actionable item in the first/last cells, respectively.
  • RE the appropriate behavior of F2 (whether it's a toggle), there's nothing to stop a grid cell from containing another grid, correct? If so, then F2 needs to be reserved to move into actionable mode for subordinate grids, right? That is, it's not a toggle (and behaves like Windows XP Explorer).

comment:11 Changed 11 years ago by Bryan Forbes

Milestone: 1.31.4

comment:12 Changed 10 years ago by Nathan Toone

Type: defectenhancement

comment:13 Changed 10 years ago by Adam Peller

Keywords: 14open added; ibm keyboard navigation selection Grid a11y removed

moving 1.4 open tickets to 1.5

comment:14 Changed 10 years ago by bill

Becky implemented keyboard support for the grid, what change are you asking for exactly?

comment:15 Changed 10 years ago by David Schwartz

We're actually already using Becky's code in this work. Thanks.

comment:16 Changed 10 years ago by bill

Owner: changed from Bryan Forbes to Eavn

looks like these are ones that evan is working on

comment:17 Changed 10 years ago by Adam Peller

Owner: changed from Eavn to Evan
Status: reopenednew

David, what does this mean? Is there still work to be done here?

comment:18 Changed 10 years ago by David Schwartz

We actually looked at Becky's code but didn't wind up using it; we implemented a pretty extensible approach covering the issues that Becky's fix addressed which can also handle keyboard for complicated widgets within cells.

comment:19 Changed 10 years ago by Adam Peller

Pls comment on this open ticket for 1.5. Where is the changeset? should this stay open? Etc

comment:20 Changed 10 years ago by David Schwartz

This should be moved to 1.6

comment:21 Changed 10 years ago by Adam Peller

Milestone: 1.51.6

comment:22 Changed 9 years ago by bill

Owner: changed from Evan to evan

comment:23 Changed 9 years ago by evan

Resolution: fixed
Status: newclosed

Fixed in [23291] by related changes for enhanced/_FocusManager.js

Refs #11734

Note: See TracTickets for help on using tickets.