Opened 11 years ago

Closed 11 years ago

#7471 closed defect (fixed)

TabContainer: Tab Container with 2 rows of labels - one label is spanning 2 rows (IE6)

Reported by: Eric Poulin Owned by:
Priority: high Milestone: 1.1
Component: Dijit Version: 1.0
Keywords: tab container ie6 Cc: epoulin@…
Blocked By: Blocking:

Description

Only in IE6 (I'm using Dojo 1.0.2) this problem occurs. When there is more than 1 row of tabs, selecting any tab makes the tab title span 2 rows and no tabs can be placed before this problem. See attachments for screenshots of the problem

Attachments (3)

screen1.jpg (75.6 KB) - added by Eric Poulin 11 years ago.
Screen Cap of error
screen2.jpg (75.6 KB) - added by Eric Poulin 11 years ago.
Screen cap of problem - worse case
tabtest.html (3.0 KB) - added by Eric Poulin 11 years ago.
test case - modified from Dojo book. (just added more tabs and increased height)

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by Eric Poulin

Attachment: screen1.jpg added

Screen Cap of error

Changed 11 years ago by Eric Poulin

Attachment: screen2.jpg added

Screen cap of problem - worse case

comment:1 Changed 11 years ago by bill

Summary: IE6: Tab Container with 2 rows - tab title is spaning 2 rows and messing up alignment of 2nd rowTabContainer: Tab Container with 2 rows of labels - one label is spanning 2 rows (IE6)

I see the problem on your screen shots but you'll need to attach a test case to reproduce. (And a patch if possible; maybe we can stick a nowrap clause into the CSS?)

Also note that things have changed a lot since 1.0.2, it's worth checking if this happens w/the latest code.

BTW if you edit your settings on trac then it will send you mail automatically w/out having to add yourself to the CC list.

Changed 11 years ago by Eric Poulin

Attachment: tabtest.html added

test case - modified from Dojo book. (just added more tabs and increased height)

comment:2 Changed 11 years ago by Eric Poulin

Added tabtest.html. This is taken from the dojo book - just added a few more tabs and increased the height since the contents cannot be seen in IE6 without increasing the height. It appears to work fine in FF. Interestingly - it only appears to be a problem in tabs that are closeable (with the X). Testcase shows problem in IE6 & IE7. Unfortuntately, I don't have a patch at the moment.

Also: I updated my trac setting - thanks for that :)

comment:3 Changed 11 years ago by Eric Poulin

And yes - the problem appears to be gone in Dojo 1.1.

comment:4 Changed 11 years ago by bill

Milestone: tbd1.1
Resolution: fixed
Status: newclosed

OK, not sure what to tell you then other than to upgrade to 1.1, or try to workaround the problem (using CSS nowrap?) until you do upgrade.

Note: See TracTickets for help on using tickets.