Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7464 closed defect (fixed)

[regression] Editor: broken in Nightly Build:17/Aug/2008

Reported by: taras Owned by: Nathan Toone
Priority: high Milestone: 1.2
Component: Editor Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

Hi

The Editor widget was broken in 17/Aug/2008. In the 16/Aug/2008 version was OK.

Tested with the following Browsers:

FF2 : Not OK (is broken)

Safari3 : NOT OK.

IE7: Is OK '''

See standard test: dijit/tests/test_Editor.html

I attached images of the test examples on all the above browsers.

Attachments (3)

editor-ff2.gif (28.7 KB) - added by taras 11 years ago.
On Firefox 2
editor-safari3.gif (32.3 KB) - added by taras 11 years ago.
On Safari3
editor-ie7.gif (21.0 KB) - added by taras 11 years ago.
Explorer 7

Download all attachments as: .zip

Change History (13)

Changed 11 years ago by taras

Attachment: editor-ff2.gif added

On Firefox 2

Changed 11 years ago by taras

Attachment: editor-safari3.gif added

On Safari3

Changed 11 years ago by taras

Attachment: editor-ie7.gif added

Explorer 7

comment:1 Changed 11 years ago by Adam Peller

console says this.editNode is undefined (see setDisabledAttr, RichText?.js line 747)

comment:2 Changed 11 years ago by Adam Peller

Owner: set to Nathan Toone

looks like it might be related to [14873]

comment:3 Changed 11 years ago by bill

The FF2 problem is (likely?) related to delays in initialization because of the iframe (we have setTimeout's in the code waiting for the iframe to initialize). That doesn't explain safari though.

I remember Nathan and I had discussions about whether the automatic attr() calls should occur before or after postCreate(). They are occuring before postCreate() now and that caused a few issues in other widgets (which we fixed). Moving them to after postCreate() might be better, although it might cause some other unforseen issues.

comment:4 Changed 11 years ago by Nathan Toone

I think that calling it before postCreate is still OK - if someone writes custom code that depends on nodes that they themselves create during postCreate, then it should be up to them to ensure that their _setXXXAttr functions work correctly.

comment:5 Changed 11 years ago by Nathan Toone

Resolution: fixed
Status: newclosed

(In [14897]) Fixes #7464 - Update RichTextEditor? to handle having its _setDisabledAttr function called before the nodes have loded. We save that we had dojo.attr("disabled") called and call it again after the nodes are fully in-place.

comment:6 Changed 11 years ago by taras

Resolution: fixed
Status: closedreopened

I am not completely sure if I need to open a new issue or reopen this, it seems to me to be related with the previous correction.

On both: Safary3 and FF2 it is impossible to write inside the textarea or choose one of the functions in the menu.

See test: dijit/tests/test_Editor.html

IE7, continues to be OK.

thanks !

Eduardo

comment:7 Changed 11 years ago by bill

Component: DijitEditor
Summary: Editor is broken in Nightly Build:17/Aug/2008[regression] Editor: broken in Nightly Build:17/Aug/2008

comment:9 Changed 11 years ago by Nathan Toone

Resolution: fixed
Status: reopenedclosed

Fixed in [14916]

comment:10 Changed 11 years ago by bill

Milestone: tbd1.2
Note: See TracTickets for help on using tickets.