Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#7433 closed defect (duplicate)

dijit.form.Button doesn't respect value of submit button in FF2 and FF3

Reported by: Bryan Forbes Owned by:
Priority: high Milestone: 1.2
Component: Dijit - Form Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

Using this markup:

<input type="submit" dojoType="dijit.form.Button" value="Login" />

Results in a button with no text on it in FF2 and FF3. It works fine in IE7. Changing the value attribute to a label attribute works fine in FF2 and FF3, but not in IE7. You end up having to do this to get it to work in all three browsers:

<input type="submit" dojoType="dijit.form.Button" value="Login" label="Login" />

This can cause inconsistency and dijit.form.Button should be changed to respect the value of the value attribute for FF2 and FF3.

Change History (3)

comment:1 Changed 11 years ago by Bryan Forbes

Resolution: duplicate
Status: newclosed

Trac gave me an error so I submitted this twice. Sorry. Duplicate of #7432.

comment:2 Changed 11 years ago by Dustin Machi

test

comment:3 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.