Opened 11 years ago

Closed 11 years ago

#7426 closed defect (worksforme)

Tree: changing text size via menu repeats background image

Reported by: thekryz Owned by:
Priority: low Milestone: tbd
Component: Dijit Version: 1.1.1
Keywords: dojo tree icons text-size IE6 broken CSS background-repeat Cc:
Blocked By: Blocking:

Description

Using the Menu in IE6 to display the text bigger or smaller breaks the dojo tree - the [+] and [-] signs are a CSS background, so they get repeated - which looks bad: Check out my screenshot (and please ignore the pixelized text).

Attachments (1)

Dojo_Bug.jpg (250.2 KB) - added by thekryz 11 years ago.
Screenshot of a broken tree because of "bigger" text-size in IE6 (german version)

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by thekryz

Attachment: Dojo_Bug.jpg added

Screenshot of a broken tree because of "bigger" text-size in IE6 (german version)

comment:1 Changed 11 years ago by bill

Summary: IE6: Changing text size via menu breaks Dojo treeTree: changing text size via menu repeats background image

Hmm, I can't reproduce this on trunk, or even on http://download.dojotoolkit.org/release-1.1.1/dojo-release-1.1.1/dijit/tests/test_Tree.html.

Can you provide a test case? Is the above link failing for you?

The tree icon doesn't have background-repeat: none specified but it does have width/height specified which achieves the same affect.

comment:2 in reply to:  1 Changed 11 years ago by thekryz

Replying to bill:

Hmm, I can't reproduce this on trunk, or even on http://download.dojotoolkit.org/release-1.1.1/dojo-release-1.1.1/dijit/tests/test_Tree.html.

Can you provide a test case? Is the above link failing for you?

The tree icon doesn't have background-repeat: none specified but it does have width/height specified which achieves the same affect.

Hi, your example works fine - just tried to change my skin to tundra (I was using nihilo before), but it shows the same problem in my frontend. I still use version 1.1.0, maybe there were some changes concerning this? I'm sorry, but at the moment it's not possible for me to provide the HTML and CSS.

comment:3 Changed 11 years ago by bill

Resolution: worksforme
Status: newclosed

Hmm, too bad, OK well I have to close this ticket then since I can't reproduce the issue (even http://download.dojotoolkit.org/release-1.1.0/dojo-release-1.1.0/dijit/tests/test_Tree.html?theme=nihilo is working fine for me).

Please reopen if you can provide a test case.

Note: See TracTickets for help on using tickets.