Opened 11 years ago

Closed 11 years ago

#7425 closed defect (invalid)

Events are occasionally missing offsetX/Y (and therefore also missing layoutX/Y)

Reported by: mrblakwell Owned by: sjmiles
Priority: high Milestone: tbd
Component: Events Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

in troubleshooting a splitcontainer bug (#7424) i found that it was being caused by offsetX/Y being undefined.

I'm unsure of what causes this to happen as it is extremely intermittent. I was able to reproduce it by resizing a SplitContainer? many times quickly, but it has happened on my first attempt to resize a splitter.

it's possible that this is a firefox(3) only bug - i have been unable to reproduce it on IE7

Change History (3)

comment:1 Changed 11 years ago by bill

Component: GeneralEvents
Owner: changed from anonymous to sjmiles

Well, what does the event look like other than those missing values? What are the other attributes of the event (including event type and target)?

comment:2 Changed 11 years ago by mrblakwell

upon further evaluation (trying to answer bill's question) i discovered that the event did in fact have layerX/layerY - and in this case it was set to 0 - i had assumed that all browsers filtered events through _fixEvent, but it seems that it's just IE.

in the SplitContainer? bug, there was an if(layerX) that was returning false as layerX was 0.

I think this can be safely closed - more info will be posted on #7424

comment:3 Changed 11 years ago by James Burke

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.