Opened 11 years ago

Closed 11 years ago

#7423 closed defect (fixed)

Tooltip: Iframes source issues (IE)

Reported by: adamff20 Owned by: bill
Priority: high Milestone: 1.2
Component: Dijit Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

There are issues with IE when configuring the source of an iframe to javascript. The source needs to be configure to a blank.htm page. There should be a global blank.htm page that all initial sources for iframes will point to. This will eliminate receiving the non-secure error message when inside a secured sight.

Change History (15)

comment:1 Changed 11 years ago by James Burke

Resolution: invalid
Status: newclosed

Do you have a particular failure case in Dojo 1.1? You can configure a blank html page by setting djConfig.dojoBlankHtmlUrl, and there is a file you can grab from dojo/resources/blank.html to use.

I thought we checked for djConfig.dojoBlankHtmlUrl when we needed an iframe. If you have a specific failure case in Dojo 1.1, please reopen the ticket with more details.

comment:2 Changed 11 years ago by adamff20

Resolution: invalid
Status: closedreopened

I am currently using DOJO 1.1.0. I did find the blank.html in the resources folder, that is great it is already there. I am currently using the dijit.tooltip in my application. The tootlip is using the popup.js located in dijit/_base/popup.js. Inside the popup.js there is a funtion called dijit._iframes. This function is setting the iframe object with the following,

var html="<iframe src='javascript:\"\"'"
					+ " style='position: absolute; left: 0px; top: 0px;"
					+ "z-index: -1; filter:Alpha(Opacity=\"0\");'>";

Setting the source of the iframe to javascript:"" causes a problem when using a secured site with https protocol. It would be great if the code would check if the dojoBlankHtmlUrl is set to a blank page. Then the src would be set to this url. I also noticed the _frames function is in multiple sections which would also need modified. Was the code changed in the newer version to accommodate this already? Is the djConfig.dojoBlankHtmlUrl currently in version 1.1.0?

comment:3 Changed 11 years ago by bill

Component: GeneralDijit
Milestone: tbd1.2
Owner: changed from anonymous to bill
Status: reopenednew
Summary: Iframes source issuesTooltip: Iframes source issues

We've been around and around the block on this one. See #812, #548 (#999), #427, #3359, #717, #608, #2390 (#2681). Browser behavior seems to vary depending on the cycle of the moon. I guess we can change popup.js to use the blank URL, although of course after nine similar bug reports I'm wary to do anything :-).

comment:4 Changed 11 years ago by adamff20

I have looked at all the bugs in the comments above. I have not seen any of the bug fixes actually use an actual blank page for the source of the iframe. Setting the src to a blank page that is actually created will work no matter what browser or version. Will this suggested be implemented and tested? This would have to be implemented in not just the popup.js in DOJO. There is more then one place where the code to create an iframe is used.

comment:5 Changed 11 years ago by bill

Well, the implementation is trivial but testing is difficult since the current code is working for me (and many other people) already.

Why don't you try making the changes needed to get things to work on your system and then submit a patch? (You'll need to sign a CLA if you haven't already)

comment:6 Changed 11 years ago by adamff20

How is is currently working for you? What version of DOJO are you using? What version of IE are you testing on? Have you tested on all version of IE with the HTTPS protocol?

comment:7 Changed 11 years ago by adamff20

I have tested the tootlip in IE 6.0.2900.2180 and 7.05.5730.11, both are showing the same error message.

comment:8 Changed 11 years ago by bill

I use the latest code in SVN, but we also tested on 1.1.1 and 1.1.0 for IE6 and IE7 (latest versions). Using test_Tooltip.html.

comment:9 Changed 11 years ago by adamff20

Did you test with the secured site? What was changed in version 1.1.1 from 1.1.0 ?

comment:10 Changed 11 years ago by bill

Yes, we tested w/the secured site. You can look up what changed between 1.1.1 and 1.1.0 using SVN, but since it worked in both versions the question seems irrelevant.

comment:11 Changed 11 years ago by adamff20

Did you do your testing with the debug parameter set to true in the djconfig?

comment:12 Changed 11 years ago by adamff20

The reason I ask this question is because with debug set to true I do not receive the error message. When I turn debug off the error message is displayed.

comment:13 Changed 11 years ago by adamff20

I have found the problem to be the same as ticket 6603. Will this be in the next version released?

comment:14 in reply to:  11 Changed 11 years ago by bill

Summary: Tooltip: Iframes source issuesTooltip: Iframes source issues (IE)

Replying to adamff20:

Did you do your testing with the debug parameter set to true in the djconfig?

As I said above, we tested with test_Toolitip.html which has isDebug set to true. However, setting it to false doesn't change anything for me.

#6603 is marked fixed which means that the changes that fixed it will be in the next release. However it doesn't seem like that's the same problem as this.

Try getting the latest code, and if things are still broken for you, then make the changes needed to get things to work on your system and then submit a patch. (You'll need to sign a CLA if you haven't already)

comment:15 Changed 11 years ago by bill

Resolution: fixed
Status: newclosed

OK, I'm just gonna check in your fix, despite the fact that it doesn't reproduce for me. Fixed in [15003].

Note: See TracTickets for help on using tickets.