Opened 11 years ago

Closed 11 years ago

#7417 closed defect (invalid)

dijit-all_zh.js syntax error when performing custom build

Reported by: tahpot Owned by: James Burke
Priority: high Milestone: tbd
Component: BuildTools Version: 1.1.1
Keywords: Cc: James Burke, Adam Peller
Blocked By: Blocking:

Description

When performing a custom build I always receive the following error:

release: ../../../test-production/dijit/form/templates/Spinner.html rhino load('./../../../test-production/dijit/nls/dijit-all_zh.js') failed. Exception: SyntaxError?: syntax error js: "jslib/i18nUtil.js", line 229: exception from uncaught JavaScript? throw: Cannot create flattened bundle for src file: ../../../test-production/dijit/nls/dijit-all_zh.js

I grabbed the latest 1.1.1-src this morning and am using that to build from.

Build parameters are:

./build.sh profile=test.production action=release releaseName=test-production releaseDir=../../../ optimize=shrinksafe layerOptimize=shrinksafe

Attachments (1)

test.production.profile.js (136 bytes) - added by tahpot 11 years ago.
Test profile

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by tahpot

Attachment: test.production.profile.js added

Test profile

comment:1 Changed 11 years ago by tahpot

When performing a custom build I always receive the following error:

release: ../../../test-production/dijit/form/templates/Spinner.html rhino load('./../../../test-production/dijit/nls/dijit-all_zh.js') failed. Exception: SyntaxError??: syntax error js: "jslib/i18nUtil.js", line 229: exception from uncaught JavaScript?? throw: Cannot create flattened bundle for src file: ../../../test-production/dijit/nls/dijit-all_zh.js

I grabbed the latest 1.1.1-src this morning and am using that to build from.

Build parameters are:

./build.sh profile=test.production action=release releaseName=test-production releaseDir=../../../ optimize=shrinksafe layerOptimize=shrinksafe

comment:2 in reply to:  description Changed 11 years ago by tahpot

Can this bug be closed?

The problem appeared to be caused by copying dojo 1.1.1-src over dojo 1.1.1, rather than simply replacing it.

comment:3 Changed 11 years ago by dante

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.