Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#7408 closed defect (fixed)

regression: Strange Cursor Problem with ValidationTextBox

Reported by: taras Owned by: bill
Priority: high Milestone: 1.2
Component: Dijit - Form Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

Hi

I found this bug, that for sure it did not appear 1 month before.

I have a ContentPane? inside a BorderContainter?. Inside both I defined a dialog. I know that this is not a typical case, in my application I have several levels of ContentPanes? and a lot of widgets inside, but this case is the minimum case that replicate the problem that I found.

Problem: cursor is not displayed inside the TextBox?. Browser: FF2 (not tested with other browsers) Version: 10/Aug/2008 but the problem happens with at least: 03/Aug/2008 and may be before.

I attached a test program that replicates the problem.

Note: The cursor reappears in the two following cases:

[1] if height: 100%; is removed from the html, body{ style. [2] If dijit.layout.ContentPane? is removed.

In my application I cannot apply those workarounds, so I am really stucked with this issue.

Thanks !

Eduardo

Attachments (4)

validationText.html (2.9 KB) - added by taras 11 years ago.
val2.html (2.4 KB) - added by bill 11 years ago.
problem only occurs when Dialog is over the BorderContainer?.
val4.html (1.6 KB) - added by bill 11 years ago.
even simpler testc case. problem occurs when <input> is over <div style="overflow:auto">
val5.html (554 bytes) - added by bill 11 years ago.
root FF2 bug (overflow: hidden <div> over overflow: auto <div>)

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by taras

Attachment: validationText.html added

comment:1 Changed 11 years ago by bill

Component: GeneralDijit
Owner: changed from anonymous to Douglas Hays

This sounds familiar (although not with such a complicated test case).

comment:2 Changed 11 years ago by Douglas Hays

Owner: changed from Douglas Hays to bill
Summary: Strange Cursor Problem with ValidationTextBoxregression: Strange Cursor Problem with ValidationTextBox

This is a regression caused by [14612].
Adding overflow:hidden to dijitDialog broke this.
Eduardo, thanks for the excellent testcase. As a workaround, add overflow:auto to your Dialog style markup.

comment:3 Changed 11 years ago by bill

Ah, the joys of browser bugs. FWIW, this only occurs when the Dialog is over the BorderContainer. I'm attaching a simplified testcase to show that. (If you move the Dialog away from the BorderContainer then you can see the cursor.

Changed 11 years ago by bill

Attachment: val2.html added

problem only occurs when Dialog is over the BorderContainer?.

Changed 11 years ago by bill

Attachment: val4.html added

even simpler testc case. problem occurs when <input> is over <div style="overflow:auto">

Changed 11 years ago by bill

Attachment: val5.html added

root FF2 bug (overflow: hidden <div> over overflow: auto <div>)

comment:4 Changed 11 years ago by taras

Thanks very much for the workaround, it works!.

you are great guys

Eduardo

comment:5 Changed 11 years ago by bill

Resolution: fixed
Status: newclosed

(In [14913]) Remove overflow: hidden from Dialog. Although it makes dragging smoother on FF2/linux, it causes a disappearing cursor problem on FF2. The bad outweighs the good. Fixes #7408, refs #5285.

comment:6 Changed 11 years ago by bill

Milestone: tbd1.2

comment:7 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.