Opened 11 years ago

Closed 9 years ago

#7396 closed defect (worksforme)

CodeViewer needs optimized interface

Reported by: nonken Owned by: nonken
Priority: high Milestone: 1.6
Component: Doc parser Version: 1.1.1
Keywords: Codeviewer Cc:
Blocked By: Blocking:

Description

As discussed with Alex, the docs code viewer needs a more userfriendly interface.

Change History (7)

comment:1 Changed 11 years ago by nonken

I see two general ways to go:

Tabs:

Pro: optimized space usage Cons: Entire code not viewable at the same time

Consecutive Buttons:

Pro: Entire code viewable at the same time Cons: Not optimized for space

I'd prefer to be able to see the entire code and find a good visual way to display everything.

comment:2 Changed 11 years ago by bill

I assume this is about the new documentation site?

+1 from me on the "see all the code at once" option. I'm not sure what the problem is w/the current version anyway; perhaps having buttons rather than something TitlePane-ish to show/hide the text is a little non-standard.

comment:3 Changed 11 years ago by nonken

Milestone: tbd1.3
Status: newassigned

comment:4 Changed 11 years ago by nonken

Milestone: 1.31.4

comment:5 Changed 10 years ago by bill

Milestone: 1.41.5

comment:6 Changed 9 years ago by bill

Milestone: 1.51.6

1.5 is released, moving remaining tickets to 1.6

comment:7 Changed 9 years ago by dante

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.