Opened 11 years ago

Closed 11 years ago

#7376 closed defect (duplicate)

[Cometd] error in unsubscribe method?

Reported by: kurtcpp Owned by: Greg Wilkins
Priority: high Milestone: tbd
Component: DojoX Cometd Version: 1.1.1
Keywords: cometd unsubscription channel Cc:
Blocked By: Blocking:

Description

Hi, My Dojo release is: 1.xx (sorry, cannot find the exact number) Cometd client's version : 0.4 (beta, May 29, 2007)

Seems that dojox.cometd.unsubscribe sends a Bayeux message on /meta/subscribe in lieu of /meta/unsubscribe, contrarily to what Bayeux specs state. Very weird that no one detected this before, I may be mistaken but dojox.cometd code is:

props = props||{};
props.channel = "/meta/subscribe";
props.subscription = channel;
delete this._subscriptions[tname];
this._sendMessage(props);
this._deferredUnsubscribes[channel] = new dojo.Deferred();
if (this._deferredSubscribes[channel]){
    this._deferredSubscribes[channel].cancel();
    delete this._deferredSubscribes[channel];
}

Change History (1)

comment:1 Changed 11 years ago by dante

Resolution: duplicate
Status: newclosed

duplicate of #6342 - fixed in trunk and 1.1.1

Note: See TracTickets for help on using tickets.