Opened 11 years ago

Closed 9 years ago

#7364 closed enhancement (wontfix)

[proposal] using fam fam fam icon set for artwork instead what we have atm.

Reported by: ergo Owned by: nonken
Priority: high Milestone: future
Component: themes Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

I think we could use iconset provided under this link

http://www.famfamfam.com/lab/icons/silk/

for new artwork of all elements like tree icons, data table, DND, Editor (especially) etc. to have a good look.

Its licensed CC 2.5 (http://creativecommons.org/licenses/by/2.5/) so it should not be an issue using it with dojo.

In my opinion it could make whole dojo UI layer look better in many places.

Change History (4)

comment:1 Changed 11 years ago by bill

severity: majorminor

Well, I think since it's CC *with attribution* the problem is that our customers would need to put attribution on their websites. I mailed Mark asking if he would want to just donate some of them outright.

We can use them freely for the demos though.

comment:2 Changed 11 years ago by dylan

Milestone: tbdfuture

comment:3 Changed 11 years ago by nonken

Status: newassigned

comment:4 Changed 9 years ago by bill

Resolution: wontfix
Status: assignedclosed

I'm going to close this as wontfix because I didn't get a response to my email to Mark and because I don't want to fight with the lawyers about whether adding fam fam is acceptable or not.

We do have some icons donated into dijit now, see dijit/icons/commonIcons.css (although not as many as fam fam)

Note: See TracTickets for help on using tickets.