Opened 11 years ago

Closed 10 years ago

#7363 closed defect (invalid)

[regression] Dojo Editor spawns multiple dijitEditorArea elements on Enter press - trunk version

Reported by: ergo Owned by:
Priority: high Milestone: future
Component: Editor Version: 1.1.1
Keywords: refactor Cc: Douglas Hays, Adam Peller
Blocked By: Blocking:

Description

Ive attached a test case file for the problem,

it contains 2 editors - one (at the top) works fine, the other one is behaving very strangely, spawns multiple dijitEditorArea elements on Enter press. Testes by me and wild_bill.

When i use dojo 1.1.1 everything is fine, on trunk build it gets buggy.

Attachments (1)

index.html (14.7 KB) - added by ergo 11 years ago.
the test case cut out from my app, forgive me the clutter, i had small amount of time to prepare this

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by ergo

Attachment: index.html added

the test case cut out from my app, forgive me the clutter, i had small amount of time to prepare this

comment:1 Changed 11 years ago by bill

Cc: Douglas Hays Adam Peller added
Milestone: tbd1.2

Unfortunately this still occurs after the rollback of the iframe stuff. Doug or Adam if you could track this down that would be great.

comment:2 Changed 11 years ago by Adam Peller

works for me, FF3/Mac

comment:3 Changed 11 years ago by bill

Component: EditorDojoX Editor
Milestone: 1.21.3
Owner: changed from liucougar to alex
Priority: highnormal
severity: criticalnormal

Actually my comment above was inaccurate. The problem occurs up until [14991] but stopped happening after [14992]. Moving this into batch of editor refactor tickets. (To reiterate, this problem is currently only affecting dojox.editor.Editor.)

comment:4 Changed 11 years ago by Adam Peller

Component: DojoX EditorEditor
Keywords: refactor added; trunk editor serious defect removed
Owner: changed from alex to liucougar

comment:5 Changed 11 years ago by bill

Milestone: 1.3future

comment:6 Changed 10 years ago by bill

Owner: liucougar deleted

comment:7 Changed 10 years ago by Jared Jurkiewicz

Resolution: invalid
Status: newclosed

Closing this as it seems related to the dead Editor refactor (which was removed).

Note: See TracTickets for help on using tickets.