Opened 11 years ago

Closed 11 years ago

#7350 closed defect (fixed)

Menu: Incorrect font on dropdown menus (all themes)

Reported by: Chris Mitchell Owned by: bill
Priority: high Milestone: 1.2
Component: Dijit - LnF Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Steps to reproduce on trunk:

Run http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_ComboBox.html

Drop down any combobox list. The dropdown menu item's font is serif vs. the font of the combobox which is sans-serif.

in Menu.css (tundra, soria, etc.) the font-family is set incorrectly to "menu". This was changed from font to font-family under [13800] (apparently to fix some other defect). "menu" is not a valid value for font-family according to http://www.w3.org/TR/REC-CSS2/fonts.html

Change History (4)

comment:1 Changed 11 years ago by Douglas Hays

Milestone: tbd1.2
Owner: changed from wildbill to bill

Targeting 1.2 since it appears to be a regression. "menu" is a system font and not the name of a valid font-family.

comment:2 Changed 11 years ago by bill

Description: modified (diff)
Status: newassigned
Summary: Incorrent font on dropdown menus (all themes)Menu: Incorrent font on dropdown menus (all themes)

Hmm OK, guess I messed that up; will fix.

comment:3 Changed 11 years ago by bill

Summary: Menu: Incorrent font on dropdown menus (all themes)Menu: Incorrect font on dropdown menus (all themes)

There's no such thing as a "incorrect font", nor would I consider a font change a regression, but I can change FF's behavior to a different font if you like.

The (menu) font is currently serif on FF and sans-serif on IE and Safari.

There's also something strange going on with the font of the ComboBox, at least on FF3, in that the font-family:sans-serif; defined in tundra.css for TextBox etc. is being overridden by the .dijitReset font: inherit;.

comment:4 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [14680]) Change Menu font-family to sans-serif. Fixes #7350. Also remove incorrect comment from dijit.css.

Note: See TracTickets for help on using tickets.