Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7339 closed defect (fixed)

GFX: Image shift in IE if surface contains a path.

Reported by: jayantbsai Owned by: Eugene Lazutkin
Priority: high Milestone: 1.3
Component: DojoX GFX Version: 1.1.1
Keywords: gfx, image, path Cc:
Blocked By: Blocking:

Description

This is a HUGE issue for us.

If a surface contains a path and an image. On applying translation transform on the surface, if the path reaches the left/top edge of the surface, the image starts shifting left/above.

I have attached a test case, here are the steps to reproduce the problem: Note that at startup, the top-left of the image matches with the center of the blue circle. Now if you start translating the group up or left. As soon as the top left of the path reaches either the top or left border of the surface and beyond, the image starts shifting. The image's top-left no longer matches with the center of the blue circle.

Attachments (1)

dojox_gfx_path_image_translate.html (1.9 KB) - added by jayantbsai 11 years ago.
Test case

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by jayantbsai

Test case

comment:1 Changed 11 years ago by Eugene Lazutkin

Milestone: tbd1.2
Priority: highestnormal
severity: criticalnormal
Status: newassigned

In IE any graphics element reaching left/top forces recalculation of left/top offsets for a parent div. It means that any relative elements will be visually shifted accordingly. It includes the image, which is implemented as an HTML element.

One possible solution is to to use one of the outer divs for such elements. Need experiments with that.

comment:2 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.2future

Moving all open ticketd to the future.

comment:3 Changed 11 years ago by Eugene Lazutkin

Should be fixed as part of #8435 --- please verify and close the ticket, or comment if the problem persists.

comment:4 Changed 11 years ago by Eugene Lazutkin

Milestone: future1.3
Resolution: fixed
Status: assignedclosed

I verified it with the included program and it works for me now.

comment:5 Changed 11 years ago by Eugene Lazutkin

(In [16588]) Checking in the work-in-progress (commented out) preparing for the merge. Refs #8551. Refs #8435. Refs #7339.

comment:6 Changed 11 years ago by Eugene Lazutkin

(In [16629]) Adding a special case for scaling/translation transforms. Refs #8551. Refs #8435. Refs #7339.

Note: See TracTickets for help on using tickets.