Opened 11 years ago

Closed 11 years ago

#7336 closed defect (fixed)

Lightbox error with grouped images on FF3

Reported by: Josh Trutwin Owned by: dante
Priority: high Milestone: 1.4
Component: Dojox Version: 1.1.1
Keywords: Cc: josh@…
Blocked By: Blocking:

Description

On FF3, when using a Lightbox with grouped images, the first image pulls up fine, pressing the Next arrow icon shows an error. The onerror in show() is being triggered. No JS errors in console. The Net panel in firebug shows the request for the first image, then the warning.png image when the arrow is pressed. Oddly, it does not show a request for the second image.

The test case I will attach is using images that are sent back from a php script, so it likely has something to do with that as the grouped images test in dojox/image/tests/test_Lightbox.html works fine.

Thanks,

Josh

Attachments (1)

lightbox_ff3_test.html (1.6 KB) - added by Josh Trutwin 11 years ago.
simple test for this issue - note, uses external image links and a php script to fetch images.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by Josh Trutwin

Attachment: lightbox_ff3_test.html added

simple test for this issue - note, uses external image links and a php script to fetch images.

comment:1 Changed 11 years ago by Adam Peller

Owner: changed from Adam Peller to dante

comment:2 Changed 11 years ago by dante

Milestone: tbdfuture

seems a weird onLoad error - will have to investigate further, hopefully during 1.3

comment:3 Changed 11 years ago by Josh Trutwin

Peter - just tested this on 1.3b1 - looks like maybe fixed???

comment:4 Changed 11 years ago by dante

Milestone: future1.4
Resolution: fixed
Status: newclosed

josh - going to mark this as fixed as per your report and the changes in [17205] ... all things seem to be working now, I tested pretty thorougly. Anything new or reproducible should be a new ticket.

Note: See TracTickets for help on using tickets.