Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#7333 closed defect (fixed)

[regression] Toolbar: disabled buttons not indicated

Reported by: bill Owned by: bill
Priority: high Milestone: 1.2
Component: Dijit - Form Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

In the editor on safari, previously disabled cut/paste buttons showed up as a "washed-out" looking image, less bright/contrasted than the enabled state. The don't seem to any more.

There seems to be more than one problem (perhaps an issue w/ToolBar itself too?) because on FF3 even in the 1.1 release the button didn't show up as disabled.

In trunk, since indent/outdent are disabled except for lists, then should show up grayed out.

Change History (7)

comment:1 Changed 11 years ago by bill

Component: EditorDijit
Description: modified (diff)
Owner: liucougar deleted
Summary: [regression] disabled buttons not indicated[regression] Toolbar: disabled buttons not indicated

Due to my change in [13650]. Normal buttons indicate disabled-ness by changing the text color from black to gray but that doesn't work for toolbar buttons since they don't have text, just an icon.

I changed the button to not use transparency because it was making the button itself transparent and the page background was bleeding through... although not sure why we can't just make the image semi-transparent. Perhaps because of browser bugs?

comment:2 Changed 11 years ago by bill

Owner: set to bill
Status: newassigned

Given problems like #7371 I don't think it's wise to use opacity settings unless necessary; I'll fix this bug by creating disabled versions of the editor icons.

comment:3 Changed 11 years ago by nonken

(In [15268]) Added disabled editor icons, refs #7333

comment:4 Changed 11 years ago by bill

Priority: normalhigh

comment:5 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [15271]) Fixes #7333: disabled editor toolbar buttons should look disabled (ie, washed out), like other toolbars.

comment:6 Changed 11 years ago by bill

(In [15272]) Make disabled editor icons black & white, to further differentiate between enabled and disabled modes. Refs #7333

comment:7 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.