Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#733 closed defect (invalid)

SplitContainer with ContentPane loaded by href, resize bar has not a good size

Reported by: jparneodo@… Owned by: neil
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

The resize bar has not the good size after loading ContentPane? from href.

SplitContainer?.paneWidth and SplitContainer?.paneHeight must be rebuilt after load.

Same problem when the ContentPane? overflow the SplitContainer? on resizing.

Attachments (7)

test_split1.html (2.1 KB) - added by jparneodo@… 13 years ago.
SplitContainer? and ContentPane? loaded externaly
splitcontainer_733_test_ie.html (3.4 KB) - added by neil 13 years ago.
splitcontainer_733_test_ie.html, testcase for ie/FF browsers no patches necessary, see comments
splitcontainer_733_test_ff.html (2.9 KB) - added by neil 13 years ago.
splitcontainer_733_test_ff.html, testcase for applied patches to be used with the FF browser form the $DOJO_ROOT/tests/widget directory, see comments
doc1.txt (727 bytes) - added by neil 13 years ago.
doc1.txt and lorem-ipsum-long.txt, bogus text files used to fill contents of Content pane for execution with testcases supplied.
lorem-ipsum-long.txt (13 bytes) - added by neil 13 years ago.
doc1.txt and lorem-ipsum-long.txt, bogus text files used to fill contents of Content pane for execution with testcases supplied.
SplitContainer.js.patch (3.1 KB) - added by neil 13 years ago.
SplitContainer?.js.patch, patch for src/widget/SplitContainer.js
HtmlWidget.js.patch (428 bytes) - added by neil 13 years ago.
HtmlWidget?.js.patch, patch for src/widget/HtmlWidget.js

Download all attachments as: .zip

Change History (15)

comment:1 Changed 14 years ago by bill

Milestone: 0.3.10.4
Resolution: invalid
Status: newclosed
Version: 0.3

Many of the demos have content panes loaded by href (like Mail.html or Panes.html), so I think this is working in general. Look at those demos and see if you are doing something differently. If necessary, please reopen the bug with a testcase.

Changed 13 years ago by jparneodo@…

Attachment: test_split1.html added

SplitContainer? and ContentPane? loaded externaly

comment:2 Changed 13 years ago by anonymous

Resolution: invalid
Status: closedreopened

comment:4 Changed 13 years ago by dylan

Owner: changed from anonymous to bill
Status: reopenednew

comment:5 Changed 13 years ago by neil

Owner: changed from bill to neil

Changed 13 years ago by neil

splitcontainer_733_test_ie.html, testcase for ie/FF browsers no patches necessary, see comments

Changed 13 years ago by neil

splitcontainer_733_test_ff.html, testcase for applied patches to be used with the FF browser form the $DOJO_ROOT/tests/widget directory, see comments

Changed 13 years ago by neil

Attachment: doc1.txt added

doc1.txt and lorem-ipsum-long.txt, bogus text files used to fill contents of Content pane for execution with testcases supplied.

Changed 13 years ago by neil

Attachment: lorem-ipsum-long.txt added

doc1.txt and lorem-ipsum-long.txt, bogus text files used to fill contents of Content pane for execution with testcases supplied.

Changed 13 years ago by neil

Attachment: SplitContainer.js.patch added

SplitContainer?.js.patch, patch for src/widget/SplitContainer.js

Changed 13 years ago by neil

Attachment: HtmlWidget.js.patch added

HtmlWidget?.js.patch, patch for src/widget/HtmlWidget.js

comment:6 Changed 13 years ago by neil

SplitContainer?.js.patch, patch for src/widget/SplitContainer.js HtmlWidget?.js.patch, patch for src/widget/HtmlWidget.js

testcases: splitcontainer_733_test_ff.html, testcase for applied patches to be used with the FF browser form the $DOJO_ROOT/tests/widget directory splitcontainer_733_test_ie.html, testcase for ie/FF browsers no patches necessary

datafiles: doc1.txt and lorem-ipsum-long.txt, bogus text files used to fill contents of Content pane for execution with testcases supplied.

There exists a patch for FF browsers. In this patch, rework was conducted on the postCreate and onRefresh methods of the SplitContainer?.js widget. The postCreate was delayed by adding to the onLoad calls (enabling the browser to correctly render the testcase), and the onRefresh reflects calculation of dimensions based upon the SplitPane?. Under this condition, the bounding box of the SplitContainer? need not be fixed. Elements filling the bounding box determine the dimensions of the rendering of the sizer bars.

The method listed above did not successfully render using the ie browser. For this case, the testcase had to explictly define all position attributes.

Testcases are available for both. For the ie testcase, it is independent of the patches supplied for the SplitContainer?.js and HtmlWidget?.js. For the FF testcase, both patches must be applied to successfully render.

comment:7 Changed 13 years ago by bill

Resolution: invalid
Status: newclosed

OK, I talked to Neil about this one. Basically the problem is that you didn't specify a height for your SplitContainer?. You need to do that. See splitcontainer_733_test_ie.html (3.4 kB) - added by neil on 09/15/06 22:22:57

comment:8 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.