Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#7328 closed defect (duplicate)

Calendar is Opened when including a DateTextBox inside a dialog

Reported by: taras Owned by:
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

Hi

When including DateTextBoxes? inside a dialog, the first box display the calendar. Correct Behavior: the calendar should not be displayed, until the Date Box is clicked.

Tested Dojo version : All the lasts Nightly Builds (but probabily it is an old problem) The problem was tested in both Browsers : FF2 and IE7

I attached a simple demonstration program, that shows the problem, see also the gif file.

Thanks !

Attachments (2)

1.gif (7.3 KB) - added by taras 11 years ago.
mytest_Dialog.html (1.9 KB) - added by taras 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by taras

Attachment: 1.gif added

Changed 11 years ago by taras

Attachment: mytest_Dialog.html added

comment:1 Changed 11 years ago by bill

Resolution: duplicate
Status: newclosed

Right, this is a dup of #7287. (The calendar opens when the widget is focused, by tabbing, clicking, or just opening the dialog) Maybe aeon is trying to tell me something. See that ticket for details.

comment:2 in reply to:  1 Changed 11 years ago by taras

Replying to bill:

Right, this is a dup of #7287. (The calendar opens when the widget is focused, by tabbing, clicking, or just opening the dialog) Maybe aeon is trying to tell me something. See that ticket for details.

Hi Bill

Now I am stucking, I can see that the resolution about #7287 is not clear and current milestone is 1.3, for me far future.

What can I do, in order to bypass this horrible "feature"?. I have some dialogs with only grids and dates.The grids are created dynamically in parallel to the display (show) of the dialog.

The behavior is such that the first time I display the dialog the, the calendar is displayed above the inputtext box, but then, the grids are started to be displayed and modify the dimensions of the dialog.

So after all widgets finished rendering inside the dialog, I have a calendar displayed more or less in the middle of the dialog and above one of the grids. I don't need to tell you the "beautiful" of this, you can imagine.

For the test I put a simple input box before the calendar, and I see that the problem is bypassed, so for sure, the focus issue is the problem.

Can you rise priority of this problem ?

thanks !

Eduardo

comment:3 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.