Opened 11 years ago

Closed 9 years ago

#7321 closed defect (wontfix)

Declaration: BorderLayout inside Declaration blank in dynamically created tab in IE

Reported by: CaptainJonesSmirk Owned by:
Priority: high Milestone: 1.5
Component: Dijit Version: 1.1.1
Keywords: borderlayout tabcontainer dynamic ie7 Cc:
Blocked By: Blocking:

Description

See http://slimetrack.com/debug/border-1 for sample.

The first static tab has a border layout created from inline source.

The second tab is created with the button in the header and displays a blank area in IE7 70.5730.13 and the contents on the layout (a simple form) in Firefox 3.0.1, Safari 3.1.2 and Opera 9.51.

This is with dojo from SVN r15613.

Attachments (2)

border-1.html (3.3 KB) - added by bill 11 years ago.
copy of testcase w/jquery stuff removed and body { height: 100% } CSS added
border-2.html (3.6 KB) - added by bill 11 years ago.
working example (of workaround)

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by CaptainJonesSmirk

ARgh, r14613, not 15613.

comment:2 Changed 11 years ago by techtonic

@capt

Tried your demo in IE6. Same problem.

Changed 11 years ago by bill

Attachment: border-1.html added

copy of testcase w/jquery stuff removed and body { height: 100% } CSS added

comment:3 Changed 11 years ago by bill

Milestone: tbd1.4
Summary: BorderLayout blank in dynamicly created tab in IE7Declaration: BorderLayout inside Declaration blank in dynamically created tab in IE

I think the problem is the use of Declaration; you've declared a new widget called cm5.Composer that contains a BorderContainer, and you add that new widget to the TabContainer. Although ContentPane has code to handle this (so that you can have a TabContainer --> ContentPane --> BorderContainer hierarchy), your new widget does not.

You might be able to get it to work by augmenting your declaration to have resize() and startup() methods that pass through to the BorderContainer.

I'll leave this ticket open for now although I'm not sure we want to do anything to support this as part of dijit or not.

comment:4 Changed 11 years ago by CaptainJonesSmirk

Trying this with http://slimetrack.com/debug/border-2 , and I'm finding that those events aren't firing in IE7 at all, but work reliably in Firefox. Might be a clue. it does work correctly in all the other browsers so in a sense, Dijit is already supporting it.

comment:5 in reply to:  4 Changed 11 years ago by techtonic

Ok, so you've deprecated the old layouts, and that means I have to use Bordercontainer. But I can't use bordercontainer on a dynamically created tab because it fails in IE 6/7?

Seems a rather big issue to me. How can this slip to 1.4, when you're boasting x-browser functionality now? Our entire application resembles Capt's,and this is unexpected. We must have splitter panes on a dynamically created tab. That it currently works in Firefox sounds promising, so maybe it's minor? If a quick patch can't fix, is there any workaround for this we can try?

comment:6 Changed 11 years ago by bill

CaptainJonesSmirk? - the methods are being called everywhere, including IE7. You just need to add isDebug: true so that you get a console on IE. The code you linked is also invalid because it's missing html, body{ height: 100%, width: 100%} . Anyway, I added an example of how to get this to work and I'll upload it; it's fairly simple.

techtonic - splitter panes on a dynamically created tab work perfectly. As I said, the problem is with Declaration.

Changed 11 years ago by bill

Attachment: border-2.html added

working example (of workaround)

comment:7 Changed 11 years ago by CaptainJonesSmirk

That appears to work around the issue in IE7 and the border container renders. :)

The only strange effect I get a extra overflowing scrollbar for the content pane that holds the tab container in Safari. But that's not related to this ticket I'm sure because we're seeing extra scroll bars in other places as well on some other layouts in Safari. http://slimetrack.com/border-4 for the wrap-up.

comment:8 Changed 11 years ago by bill

Milestone: 1.41.5

bumping 1.4 tickets to 1.5, and most 1.3 tickets to 1.4

comment:9 Changed 9 years ago by bill

Resolution: wontfix
Status: newclosed

Closing this as wontfix, please use the workaround I listed above in the attached border-2.html file.

Note: See TracTickets for help on using tickets.