Opened 11 years ago

Closed 10 years ago

#7275 closed defect (worksforme)

[regression] Editor: 2 mouse clicks to focus 2nd test editor

Reported by: Douglas Hays Owned by: liucougar
Priority: high Milestone: 1.3
Component: Editor Version: 1.1.1
Keywords: refactor Cc:
Blocked By: Blocking:

Description

Run test_Editor.html in IE6 (I'm testing on [14587]).
Mouse wheel down to the 2nd editor widget (Created from div, auto-expanding), making sure the entire widget is in view, and click to focus the 1st line of content text.
Nothing happens, click again and the input cursor is shown.
The other editor widgets on the same page do not have this problem.
The same problem happens when you scroll using the scrollbar, but you have to fight a jump-focus problem that doesn't happen on mousewheel.
Setting the milestone to 1.2 since this is a regression from 1.1.1.

Change History (6)

comment:1 Changed 11 years ago by bill

Summary: Editor: 2 mouse clicks to focus 2nd test editor[regression] Editor: 2 mouse clicks to focus 2nd test editor

comment:2 Changed 11 years ago by Douglas Hays

Seems to be caused by [13382].

comment:3 Changed 11 years ago by bill

Component: EditorDojoX Editor
Milestone: 1.21.3
Owner: changed from liucougar to alex

And [13382] was cause by [13373], see #6582.

comment:4 Changed 11 years ago by Adam Peller

Component: DojoX EditorEditor
Keywords: refactor added
Owner: changed from alex to liucougar

comment:5 Changed 11 years ago by bill

Milestone: 1.3future

comment:6 Changed 10 years ago by Douglas Hays

Milestone: future1.3
Resolution: worksforme
Status: newclosed

could not recreate with [16552]

Note: See TracTickets for help on using tickets.