Opened 11 years ago

Closed 10 years ago

#7274 closed defect (fixed)

[regression] Editor: weird scrolling on focus

Reported by: Douglas Hays Owned by: Douglas Hays
Priority: high Milestone: 1.3
Component: Editor Version: 1.1.1
Keywords: refactor Cc:
Blocked By: Blocking:

Description

Run test_Editor.html in IE6 (I'm testing on [14587]).
Scroll down to the 3rd editor widget (Optional toolbar buttons), making sure the entire widget is in view, and click to focus the 1st line of content text.
Scroll all the way back to the top, and click on the 1st line of text in the 1st editor (Created from div).
The cursor goes to the end of the 2nd line instead of the 1st line where it was clicked and the editor's 2nd line scrolls to the top of the screen.
Setting the milestone to 1.2 since this is a regression from 1.1.1.

Change History (10)

comment:1 Changed 11 years ago by Douglas Hays

The above failing scenario should have said to use the the mouse wheel to scroll and not the scrollbar. Clicking the scrollbar also causes weird, but different scrolling problems that were also not in 1.1.1. But it's probably all related.

comment:2 Changed 11 years ago by bill

Summary: Editor: weird scrolling on focus[regression] Editor: weird scrolling on focus

comment:3 Changed 11 years ago by Douglas Hays

Seems to start misbehaving with [13415].

comment:4 Changed 11 years ago by bill

Component: EditorDojoX Editor
Milestone: 1.21.3
Owner: changed from liucougar to alex

comment:5 Changed 11 years ago by Adam Peller

Component: DojoX EditorEditor
Keywords: refactor added
Owner: changed from alex to liucougar

comment:6 Changed 11 years ago by bill

Milestone: 1.3future

comment:7 Changed 10 years ago by Douglas Hays

Resolution: worksforme
Status: newclosed

I could not recreate this since the refactor was backed out - tested on [16546]

comment:8 Changed 10 years ago by Douglas Hays

Resolution: worksforme
Status: closedreopened

Oops, just recreated it.

comment:9 Changed 10 years ago by Douglas Hays

Milestone: future1.3
Owner: changed from liucougar to Douglas Hays
Status: reopenednew

moveToBookmark is being called before the input caret appears which upsets IE

comment:10 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [16555]) Fixes #7274, #8476. On mousedown in IE, remove previous saved cursor position, and additionally set the cursor to the end if the event was to empty space.

Note: See TracTickets for help on using tickets.