Opened 11 years ago

Closed 11 years ago

#7271 closed defect (invalid)

Regression: dijit.ContentPane

Reported by: Chris Mitchell Owned by: bill
Priority: high Milestone: 1.2
Component: Dijit Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Douglas Hays)

This regression has been found in trunk revision 14584:

dijit.form.ContentPane? on 1.1:

resize: function(size){

...

var node = this.containerNode
this.domNode,
mb = dojo.mixin(dojo.marginBox(node), size
{});

dijit.form.ContentPane? on 1.2

resize: function(size){

... var node = this.containerNode,<- null on subclasses

mb = dojo.mixin(dojo.marginBox(node), size
{}); <- NPE

ContentPane? on 1.2 expects to have this.containerNode which is created on postCreate(). However it should not be expected because the subclasses (PagePropertyPane? in this case) may not have it.

Change History (2)

comment:1 Changed 11 years ago by Douglas Hays

Description: modified (diff)
Owner: set to bill

this was changed in [13521].

comment:2 Changed 11 years ago by bill

Resolution: invalid
Status: newclosed

PagePropertyPane.postCreate() should be calling ContentPane.postCreate(), and thus containerNode will be defined. Sounds like you are missing a this.inherited(arguments) call.

Note: See TracTickets for help on using tickets.