Opened 11 years ago

Closed 11 years ago

#7265 closed defect (worksforme)

Tab Container: focus not showing when first tab in group is focused

Reported by: Becky Gibson Owned by:
Priority: high Milestone: 1.2
Component: Dijit Version: 1.1.1
Keywords: a11y Cc: davidb, Joseph Scheuhammer
Blocked By: Blocking:

Description

When you first tab into a tab Container, a tab has focus but it is not visible via a focus rectangle. This really should be fixed for 1.2 since it affects a11y. I tried to track it down to a particular build but archive.dojotoolkit.org has not files for the builds from July 16 - 22. Focus works properly in the July 15 build. I didn't see anything obvious in the checkins.

I double checked that it was not [14496]

load tests/layout/test_TabContainer.html - press tab, focus is on Tab 2 but there is no focus rectangle. If you press the right arrow focus will go to tab 3 and will be shown. Likewise, with focus on Inlined SubTab? Container tab, pressing tab will set focus to SubTab2 but the focus rectangle is not shown.

Change History (1)

comment:1 Changed 11 years ago by bill

Resolution: worksforme
Status: newclosed

Hmm, I'm not able to reproduce this (at least not on FF3/mac). I get the focus rectangle.

At first I thought there was a problem when tabbing in from the address bar, but then I realized that it follows these steps:

  1. go to google search input
  2. focus on the viewport itself (dotted line around edge of whole window)
  3. focus goes to the element after the previously focused element (ie, if Tab2 was previously focused, then focus goes to the button
Note: See TracTickets for help on using tickets.